summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-05-22 23:23:13 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-05-23 18:56:43 -0400
commit870c3fc67cd66cfd90bf262433f5141e76fc2145 (patch)
tree776fb15ac1fbbf45dc61e0424ccb832c9ecda022 /configure.ac
parente3a01af49b01b870dd7739bf60e7be4621754c5a (diff)
downloadphosphor-dbus-monitor-870c3fc67cd66cfd90bf262433f5141e76fc2145.tar.gz
phosphor-dbus-monitor-870c3fc67cd66cfd90bf262433f5141e76fc2145.zip
build: General build refactoring
Add vars.mk for variable sharing across makefiles. Stub and rename example YAML file and template. Content to be re-introduced as support is added. Move generated C++ to a header file. Add input YAML path option to configure. Change-Id: Ia06e392e8b120b1e1d8614046064fa432a6f9e18 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 38e8d79..e738f3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,5 +50,8 @@ AS_IF([test "x$enable_oe_sdk" == "xyes"],
AC_SUBST([OESDK_TESTCASE_FLAGS], [$testcase_flags])
)
+AC_ARG_VAR(YAML_PATH, [The path to the yaml config files.])
+AS_IF([test "x$YAML_PATH" == "x"], [YAML_PATH="$srcdir/example"])
+
AC_CONFIG_FILES([Makefile src/Makefile])
AC_OUTPUT
OpenPOWER on IntegriCloud