summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-12-09 14:30:45 -0600
committerPatrick Williams <patrick@stwcx.xyz>2017-01-18 09:40:31 -0600
commit0be05ee21426bdb5e77337560e99324d0a2f3301 (patch)
tree147eb69babc84fcb8d6ea322d9c4038a8f6e4aea /configure.ac
parent6d51435b5239d970d8265256c4b1a66b838f3b58 (diff)
downloadphosphor-dbus-interfaces-0be05ee21426bdb5e77337560e99324d0a2f3301.tar.gz
phosphor-dbus-interfaces-0be05ee21426bdb5e77337560e99324d0a2f3301.zip
build: autotools files for libphosphor_dbus.so
Use the interface YAML files present to generate the server.cpp and server.hpp files, build them into a shared library, and install. Change-Id: Ib08704c399975f42aa77f911a7bc7dc33bacba99 Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 39 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..bba445b
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,39 @@
+# Initialization
+AC_PREREQ([2.69])
+AC_INIT([phosphor-dbus-interfaces], [1.0], [https://github.com/openbmc/phosphor-dbus-interfaces])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([subdir-objects -Wall -Werror foreign dist-xz])
+AM_SILENT_RULES([yes])
+
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_CC
+AM_PROG_AR
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+AC_PROG_SED
+AC_CHECK_PROG([FIND], find, find)
+AC_CHECK_PROG([BASENAME], basename, basename)
+AC_CHECK_PROG([DIRNAME], dirname, dirname)
+
+# Checks for libraries.
+PKG_CHECK_MODULES([SYSTEMD], [libsystemd >= 221],,
+ [AC_MSG_ERROR(["systemd required and not found."])])
+# TODO: Add sdbusplus.
+
+# Checks for header files.
+
+# Checks for typedefs, structures, and compiler characteristics.
+AX_CXX_COMPILE_STDCXX_14([noext])
+AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CFLAGS])
+AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CXXFLAGS])
+
+# Checks for library functions.
+LT_INIT([dlopen disable-static shared])
+LT_LIB_DLLOAD
+
+# Create configured output
+AC_CONFIG_FILES([Makefile.interfaces],
+ [./generate_makefile.sh > Makefile.interfaces])
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT
OpenPOWER on IntegriCloud