summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2018-08-27 11:29:31 -0500
committerAndrew Geissler <geissonator@yahoo.com>2018-08-27 11:29:31 -0500
commit94998a64fadcdbb08da30058278a0372ae7423bb (patch)
treea5f25a89d33e0201c8e7bc6dd651674aa87d8341 /Makefile.am
parent4132f4b6b1de57a993af9bd2bcd039957786a227 (diff)
downloadphosphor-dbus-interfaces-94998a64fadcdbb08da30058278a0372ae7423bb.tar.gz
phosphor-dbus-interfaces-94998a64fadcdbb08da30058278a0372ae7423bb.zip
Add -flto to CXXFLAGS
Per openbmc/openbmc#3364, adding -flto to CXX flags in order to reduce overall library and binary sizes. Ref: https://gcc.gnu.org/wiki/LinkTimeOptimization Change-Id: I2e1ba4b77af1c8419f7f586993957f9346d7a24a Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2570163..933e339 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,7 @@ nobase_include_HEADERS = ## These get filled in by Makefile.interfaces
libphosphor_dbusdir = ${libdir}
libphosphor_dbus_LTLIBRARIES = libphosphor_dbus.la
libphosphor_dbus_la_LDFLAGS = $(SYSTEMD_LIBS) $(SDBUSPLUS_LIBS) -version-info 0:0:0 -shared
-libphosphor_dbus_la_CXXFLAGS = $(SYSTEMD_CFLAGS) $(SDBUSPLUS_CFLAGS)
+libphosphor_dbus_la_CXXFLAGS = $(SYSTEMD_CFLAGS) $(SDBUSPLUS_CFLAGS) -flto
BUILT_SOURCES = libphosphor_dbus.cpp
CLEANFILES = libphosphor_dbus.cpp
OpenPOWER on IntegriCloud