summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-12-09 14:30:45 -0600
committerPatrick Williams <patrick@stwcx.xyz>2017-01-18 09:40:31 -0600
commit0be05ee21426bdb5e77337560e99324d0a2f3301 (patch)
tree147eb69babc84fcb8d6ea322d9c4038a8f6e4aea /Makefile.am
parent6d51435b5239d970d8265256c4b1a66b838f3b58 (diff)
downloadphosphor-dbus-interfaces-0be05ee21426bdb5e77337560e99324d0a2f3301.tar.gz
phosphor-dbus-interfaces-0be05ee21426bdb5e77337560e99324d0a2f3301.zip
build: autotools files for libphosphor_dbus.so
Use the interface YAML files present to generate the server.cpp and server.hpp files, build them into a shared library, and install. Change-Id: Ib08704c399975f42aa77f911a7bc7dc33bacba99 Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..7ac8318
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,16 @@
+AM_DEFAULT_SOURCE_EXT = .cpp
+
+nobase_include_HEADERS = ## These get filled in by Makefile.interfaces
+
+libphosphor_dbusdir = ${libdir}
+libphosphor_dbus_LTLIBRARIES = libphosphor_dbus.la
+libphosphor_dbus_la_LDFLAGS = $(SYSTEMD_LIBS) -version-info 0:0:0 -shared
+libphosphor_dbus_la_CXXFLAGS = $(SYSTEMD_CFLAGS)
+
+BUILT_SOURCES = libphosphor_dbus.cpp
+CLEANFILES = libphosphor_dbus.cpp
+
+clean-local: clean-dbus
+
+-include Makefile.interfaces
+
OpenPOWER on IntegriCloud