summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3044e38..b883f94 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,4 @@
+if !INSTALL_ERROR_YAML
# Build these headers, don't install them
noinst_HEADERS = \
occ_pass_through.hpp \
@@ -75,3 +76,10 @@ org/open_power/OCC/Device/error.cpp: ${top_srcdir}/org/open_power/OCC/Device.err
$(SDBUSPLUSPLUS) -r $(top_srcdir) error exception-cpp org.open_power.OCC.Device > $@
SUBDIRS = . test
+endif
+
+# Export error YAML to shared location
+yamldir = ${datadir}/phosphor-dbus-yaml/yaml
+nobase_yaml_DATA = \
+ org/open_power/OCC/Device.errors.yaml \
+ org/open_power/OCC/Device.metadata.yaml
OpenPOWER on IntegriCloud