summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 361af89..548e7ff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,10 +19,19 @@ openpower_occ_control_SOURCES = \
occ_finder.cpp
BUILT_SOURCES = org/open_power/OCC/Device/error.hpp \
- org/open_power/OCC/Device/error.cpp
+ org/open_power/OCC/Device/error.cpp \
+ occ_sensor.hpp
CLEANFILES = ${BUILT_SOURCES}
+REQ_MAKO_FILE ?= ${top_srcdir}/occ_sensor.mako.hpp
+REQ_PY_SCRIPT ?= ${top_srcdir}/sensor_gen.py
+
+EXTRA_DIST = $(REQ_MAKO_FILE) $(REQ_PY_SCRIPT)
+
+occ_sensor.hpp: ${REQ_PY_SCRIPT} ${REQ_MAKO_FILE}
+ $(AM_V_GEN) ${PYTHON} ${REQ_PY_SCRIPT} -i ${YAML_PATH} > $@
+
openpower_occ_control_LDFLAGS = \
$(SDBUSPLUS_LIBS) \
$(PHOSPHOR_LOGGING_LIBS) \
OpenPOWER on IntegriCloud