summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-05-08 07:11:22 -0500
committerDeepak Kodihalli <dkodihal@in.ibm.com>2017-06-13 08:18:25 -0500
commitfd358d18b8b7f73204cc482f3b29f49a50fda214 (patch)
treeb231ebe86d27090357161ab7ce68c8ba2fb6bacd /Makefile.am
parentd13694a0658a9fc5914b06eadcaabe9d671f70b2 (diff)
downloadopenpower-occ-control-fd358d18b8b7f73204cc482f3b29f49a50fda214.tar.gz
openpower-occ-control-fd358d18b8b7f73204cc482f3b29f49a50fda214.zip
Create OCC pass-through objects
Create OCC pass-through d-bus objects when corresponding CPU objects are created in the inventory. Resolves openbmc/openbmc#1450. Change-Id: I8da879f51ebef8dcc3d25358def81c5e0dce0617 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 50d23da..b68f9a0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,9 @@
# Build these headers, don't install them
noinst_HEADERS = \
- occ_finder.hpp \
occ_pass_through.hpp
sbin_PROGRAMS = openpower-occ-control
openpower_occ_control_SOURCES = \
- occ_finder.cpp \
occ_pass_through.cpp \
app.cpp \
org/open_power/OCC/PassThrough/error.cpp
@@ -18,7 +16,8 @@ CLEANFILES = ${BUILT_SOURCES}
openpower_occ_control_LDFLAGS = \
$(SDBUSPLUS_LIBS) \
$(PHOSPHOR_LOGGING_LIBS) \
- $(OPENPOWER_DBUS_INTERFACES_LIBS)
+ $(OPENPOWER_DBUS_INTERFACES_LIBS) \
+ -lstdc++fs
openpower_occ_control_CXXFLAGS =
$(SDBUSPLUS_CFLAGS) \
OpenPOWER on IntegriCloud