summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorEdward A. James <eajames@us.ibm.com>2017-10-06 10:53:55 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-11-17 20:50:09 +0000
commit636577f44fe3fc951538c1119ed0da8ac9a40932 (patch)
treecded6020e29358bd8913d6f7b2b5d56cd8f42204 /Makefile.am
parent5e177970328acb51d7213d137b6b47cde0451780 (diff)
downloadopenpower-occ-control-636577f44fe3fc951538c1119ed0da8ac9a40932.tar.gz
openpower-occ-control-636577f44fe3fc951538c1119ed0da8ac9a40932.zip
Add OCC present count detection and watch
Add a Presence child class of Error to handle detecting the number of OCCs available. Add an instance of this Presence class if the Device detects that it is the master OCC, since the number of present OCCs is only reported by the master OCC. When a change to the number of OCCs reported is detected, compare with the number of OCCs determined to be active by the Manager, and if there is a mismatch, follow the usual error path (reset OCC, etc). Partially resolves openbmc/openbmc#2285 See https://gerrit.openbmc-project.xyz/#/c/7843/ Change-Id: Idbaca52b307992d9b01fe15439ab746ef6d64397 Signed-off-by: Edward A. James <eajames@us.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a2b263e..3044e38 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,7 @@ noinst_HEADERS = \
occ_errors.hpp \
occ_events.hpp \
occ_finder.hpp \
+ occ_presence.hpp \
utils.hpp
noinst_LTLIBRARIES = libocc_control.la
@@ -21,6 +22,7 @@ libocc_control_la_SOURCES = \
occ_status.cpp \
occ_device.cpp \
occ_errors.cpp \
+ occ_presence.cpp \
powercap.cpp \
org/open_power/OCC/Device/error.cpp \
occ_finder.cpp \
OpenPOWER on IntegriCloud