summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2017-07-13 17:02:23 +0800
committerLei YU <mine260309@gmail.com>2017-08-28 10:31:42 +0800
commit0ab90ca75b825db8e2427ea62ea3ee212c9accbb (patch)
tree6d7934495cf7233f54f5bd882469056c4f700142 /Makefile.am
parent3ace7576176afed9196fb308c766de6b1252d3ea (diff)
downloadopenpower-occ-control-0ab90ca75b825db8e2427ea62ea3ee212c9accbb.tar.gz
openpower-occ-control-0ab90ca75b825db8e2427ea62ea3ee212c9accbb.zip
Add I2C OCC support for P8 systems
P8 system uses I2C OCC and it uses different driver for occ-hwmon. Add `--enable-i2c-occ` configure option to enable the support. It searches i2c device names in sysfs to get all occ-hwmon devices and use the i2c device name to bind/unbind the driver. The occ control object path for I2C OCC hwmon becomes something like /org/open_power/control/3_0050, where 3_0050 is the i2c address. Change-Id: I8b9d8d4429c563528dc88fb2679b265c53d7a2d5 Signed-off-by: Lei YU <mine260309@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index aecbebb..d71d6e5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,6 +18,7 @@ openpower_occ_control_SOURCES = \
powercap.cpp \
org/open_power/OCC/Device/error.cpp \
occ_finder.cpp \
+ i2c_occ.cpp \
utils.cpp
BUILT_SOURCES = org/open_power/OCC/Device/error.hpp \
OpenPOWER on IntegriCloud