summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 09cfed9..96bb1dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,10 @@ AS_IF([test "x$enable_libopenpower_dbus" != "xno"], [
AS_IF([test "x$SDBUSPLUSPLUS" == "x"],
AC_MSG_ERROR([Cannot find sdbus++]))
+ # Checks for libraries.
+ AX_PKG_CHECK_MODULES([SYSTEMD], [], [libsystemd >= 221], [],)
+ AX_PKG_CHECK_MODULES([SDBUSPLUS], [], [sdbusplus], [],)
+
# Check for baseline language coverage in the compiler for the C++14 standard
AX_CXX_COMPILE_STDCXX_17([noext])
AX_APPEND_COMPILE_FLAGS([-Wall -Werror], [CFLAGS])
OpenPOWER on IntegriCloud