summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-03-14 07:17:01 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-03-28 20:54:05 +0000
commit77bc009e86eb30c9c8911d1727beb5923bd02551 (patch)
tree94be5216644a80a6b34fa73e97af7da4995474ba /Makefile.am
parent70e4fcf5af8913ba2da4ba7b1a4e77c17adcd6b3 (diff)
downloadopenpower-dbus-interfaces-77bc009e86eb30c9c8911d1727beb5923bd02551.tar.gz
openpower-dbus-interfaces-77bc009e86eb30c9c8911d1727beb5923bd02551.zip
build: autotools files for libopenpower_dbus.so
Use the interface YAML files present to generate the server.cpp and server.hpp files, build them into a shared library, and install. Change-Id: I87217ba299c04b3eb3fac819463707a103a287b5 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..6e63e81
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,15 @@
+AM_DEFAULT_SOURCE_EXT = .cpp
+
+nobase_include_HEADERS = ## These get filled in by Makefile.interfaces
+
+libopenpower_dbusdir = ${libdir}
+libopenpower_dbus_LTLIBRARIES = libopenpower_dbus.la
+libopenpower_dbus_la_LDFLAGS = $(SDBUSPLUS_LIBS) -version-info 0:0:0 -shared
+libopenpower_dbus_la_CXXFLAGS = $(SDBUSPLUS_CFLAGS)
+
+BUILT_SOURCES = libopenpower_dbus.cpp
+CLEANFILES = libopenpower_dbus.cpp
+
+clean-local: clean-dbus
+
+-include Makefile.interfaces
OpenPOWER on IntegriCloud