summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDeepak Kodihalli <dkodihal@in.ibm.com>2017-02-20 01:20:08 -0600
committerPatrick Williams <patrick@stwcx.xyz>2017-02-21 16:35:57 +0000
commite8c4ffd43623eeddb9750faf801531813dcb05ad (patch)
treed1d4c7f1156f4afadc9eac5b25f7c7aa6d1efbc1 /configure.ac
parentbe05107252a78bc4aced2d228e99b724ca65d2dd (diff)
downloadipmi-fru-parser-e8c4ffd43623eeddb9750faf801531813dcb05ad.tar.gz
ipmi-fru-parser-e8c4ffd43623eeddb9750faf801531813dcb05ad.zip
build : provide extra properties yaml as config
Make it possible for the openpower-vpd-parser recipe to be able to supply the extra properties YAML as configurable input. Use extra-properties-example.yaml as input. Change-Id: I3cfffa6bb9709b4dbf5c487ab198960cc52e3863 Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8ff7c91..c1ef974 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,9 @@ AS_IF([test "x$enable_oe_sdk" == "xyes"],
AS_IF([test "x$YAML_GEN" == "x"], [YAML_GEN="example.yaml"])
FRUGEN="$PYTHON $srcdir/scripts/fru_gen.py -i $YAML_GEN"
AC_SUBST(FRUGEN)
+AS_IF([test "x$PROP_YAML" == "x"], [PROP_YAML="extra-properties-example.yaml"])
+PROPGEN="$PYTHON $srcdir/scripts/extra-properties.py -e $PROP_YAML"
+AC_SUBST(PROPGEN)
# Create configured output
AC_CONFIG_FILES([Makefile])
OpenPOWER on IntegriCloud