summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/Config.in1
-rw-r--r--package/gconf/Config.in19
-rw-r--r--package/gconf/gconf.hash4
-rw-r--r--package/gconf/gconf.mk16
4 files changed, 40 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index e6e37cff00..b7ca5d7cbe 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1456,6 +1456,7 @@ menu "Other"
source "package/elfutils/Config.in"
source "package/fftw/Config.in"
source "package/flann/Config.in"
+ source "package/gconf/Config.in"
source "package/gflags/Config.in"
source "package/glibmm/Config.in"
source "package/glm/Config.in"
diff --git a/package/gconf/Config.in b/package/gconf/Config.in
new file mode 100644
index 0000000000..a68287525b
--- /dev/null
+++ b/package/gconf/Config.in
@@ -0,0 +1,19 @@
+config BR2_PACKAGE_GCONF
+ bool "gconf"
+ depends on BR2_TOOLCHAIN_HAS_THREADS # dbus, libglib2
+ depends on BR2_USE_MMU # dbus, libglib2
+ depends on BR2_USE_WCHAR # libglib2
+ select BR2_PACKAGE_DBUS
+ select BR2_PACKAGE_DBUS_GLIB
+ select BR2_PACKAGE_LIBGLIB2
+ select BR2_PACKAGE_LIBXML2
+ help
+ GConf was a system used by the GNOME desktop environment for storing
+ configuration settings for the desktop and applications. It is similar
+ to the Windows Registry.
+
+ https://projects.gnome.org/gconf/
+
+comment "gconf needs a toolchain w/ threads, wchar"
+ depends on BR2_USE_MMU
+ depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
diff --git a/package/gconf/gconf.hash b/package/gconf/gconf.hash
new file mode 100644
index 0000000000..24d0cf9b17
--- /dev/null
+++ b/package/gconf/gconf.hash
@@ -0,0 +1,4 @@
+# http://ftp.acc.umu.se/pub/gnome/sources/GConf/3.2/GConf-3.2.6.sha256sum
+sha256 1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c GConf-3.2.6.tar.xz
+# License files, locally calculated
+sha256 94b03f1a60a7fd5007149530626a895a6ef5a8b9342abfd56860c5f3956f5d23 COPYING
diff --git a/package/gconf/gconf.mk b/package/gconf/gconf.mk
new file mode 100644
index 0000000000..39df95fbd2
--- /dev/null
+++ b/package/gconf/gconf.mk
@@ -0,0 +1,16 @@
+################################################################################
+#
+# gconf
+#
+################################################################################
+
+GCONF_VERSION = 3.2.6
+GCONF_SOURCE = GConf-${GCONF_VERSION}.tar.xz
+GCONF_SITE = http://ftp.gnome.org/pub/gnome/sources/GConf/3.2
+GCONF_CONF_OPTS = --disable-orbit
+GCONF_DEPENDENCIES = dbus dbus-glib libglib2 libxml2 \
+ host-intltool $(TARGET_NLS_DEPENDENCIES)
+GCONF_LICENSE = LGPL-2.0+
+GCONF_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud