summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/Config.in1
-rw-r--r--package/rtl8723bu/Config.in10
-rw-r--r--package/rtl8723bu/rtl8723bu.hash2
-rw-r--r--package/rtl8723bu/rtl8723bu.mk20
4 files changed, 33 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 877cbf2cbe..aa111e48e6 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -484,6 +484,7 @@ endmenu
source "package/rs485conf/Config.in"
source "package/rtl8188eu/Config.in"
source "package/rtl8723bs/Config.in"
+ source "package/rtl8723bu/Config.in"
source "package/rtl8821au/Config.in"
source "package/sane-backends/Config.in"
source "package/sdparm/Config.in"
diff --git a/package/rtl8723bu/Config.in b/package/rtl8723bu/Config.in
new file mode 100644
index 0000000000..266a794a7d
--- /dev/null
+++ b/package/rtl8723bu/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_RTL8723BU
+ bool "rtl8723bu"
+ depends on BR2_LINUX_KERNEL
+ help
+ rtl8723bu wifi driver
+
+ https://github.com/lwfinger/rtl8723bu
+
+comment "rtl8723bu needs a Linux kernel to be built"
+ depends on !BR2_LINUX_KERNEL
diff --git a/package/rtl8723bu/rtl8723bu.hash b/package/rtl8723bu/rtl8723bu.hash
new file mode 100644
index 0000000000..ef4eddaa63
--- /dev/null
+++ b/package/rtl8723bu/rtl8723bu.hash
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 da04cffc306d9738abdc67d234b8948db6ca97ed77760c68d99d18817839a513 rtl8723bu-b922079a090dcaad58179d478442ff97f18521c9.tar.gz
diff --git a/package/rtl8723bu/rtl8723bu.mk b/package/rtl8723bu/rtl8723bu.mk
new file mode 100644
index 0000000000..942b13bbf6
--- /dev/null
+++ b/package/rtl8723bu/rtl8723bu.mk
@@ -0,0 +1,20 @@
+################################################################################
+#
+# rtl8723bu
+#
+################################################################################
+
+RTL8723BU_VERSION = b922079a090dcaad58179d478442ff97f18521c9
+RTL8723BU_SITE = $(call github,lwfinger,rtl8723bu,$(RTL8723BU_VERSION))
+RTL8723BU_LICENSE = GPL-2.0, proprietary (*.bin firmware blobs)
+
+RTL8723BU_MODULE_MAKE_OPTS = \
+ KVER=$(LINUX_VERSION_PROBED) \
+ KSRC=$(LINUX_DIR)
+
+define RTL8723BU_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 644 $(@D)/rtl8723b_fw.bin $(TARGET_DIR)/lib/firmware/rtlwifi/rtl8723b_fw.bin
+endef
+
+$(eval $(kernel-module))
+$(eval $(generic-package))
OpenPOWER on IntegriCloud