summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/liquid-dsp/Config.in3
-rw-r--r--package/pixman/pixman.mk5
2 files changed, 8 insertions, 0 deletions
diff --git a/package/liquid-dsp/Config.in b/package/liquid-dsp/Config.in
index a2cd21cf05..ad887cb561 100644
--- a/package/liquid-dsp/Config.in
+++ b/package/liquid-dsp/Config.in
@@ -1,10 +1,13 @@
comment "liquid-dsp requires a (e)glibc/musl toolchain w/ dynamic library"
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC
depends on !(BR2_TOOLCHAIN_USES_GLIBC || BR2_TOOLCHAIN_USES_MUSL) || BR2_STATIC_LIBS
config BR2_PACKAGE_LIQUID_DSP
bool "liquid-dsp"
depends on BR2_TOOLCHAIN_USES_GLIBC || BR2_TOOLCHAIN_USES_MUSL
depends on !BR2_STATIC_LIBS
+ # These result in internal compiler error
+ depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC
help
Liquid-DSP is a free and open-source signal processing
library for software-defined radios written in C. Its
diff --git a/package/pixman/pixman.mk b/package/pixman/pixman.mk
index 29b01eea12..a130af97fb 100644
--- a/package/pixman/pixman.mk
+++ b/package/pixman/pixman.mk
@@ -32,5 +32,10 @@ ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII),y)
PIXMAN_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -DPIXMAN_NO_TLS"
endif
+# Altivec detection isn't reliable for CS toolchains
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC),y)
+PIXMAN_CONF_OPTS += --disable-vmx
+endif
+
$(eval $(autotools-package))
$(eval $(host-autotools-package))
OpenPOWER on IntegriCloud