summaryrefslogtreecommitdiffstats
path: root/package/weston/weston.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/weston/weston.mk')
-rw-r--r--package/weston/weston.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/package/weston/weston.mk b/package/weston/weston.mk
index 63c43a3231..3a0189f1ae 100644
--- a/package/weston/weston.mk
+++ b/package/weston/weston.mk
@@ -19,7 +19,6 @@ WESTON_DEPENDENCIES = host-pkgconf wayland wayland-protocols \
WESTON_CONF_OPTS = \
--with-dtddir=$(STAGING_DIR)/usr/share/wayland \
--disable-xwayland \
- --disable-x11-compositor \
--disable-wayland-compositor \
--disable-headless-compositor \
--disable-colord \
@@ -103,6 +102,15 @@ else
WESTON_CONF_OPTS += --disable-rpi-compositor
endif # BR2_PACKAGE_WESTON_RPI
+ifeq ($(BR2_PACKAGE_WESTON_X11),y)
+WESTON_CONF_OPTS += \
+ --enable-x11-compositor \
+ WESTON_NATIVE_BACKEND=x11-backend.so
+WESTON_DEPENDENCIES += libxcb xlib_libX11
+else
+WESTON_CONF_OPTS += --disable-x11-compositor
+endif
+
ifeq ($(BR2_PACKAGE_LIBVA),y)
WESTON_CONF_OPTS += --enable-vaapi-recorder
WESTON_DEPENDENIES += libva
OpenPOWER on IntegriCloud