summaryrefslogtreecommitdiffstats
path: root/package/supervisor/supervisor.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/supervisor/supervisor.mk')
-rw-r--r--package/supervisor/supervisor.mk22
1 files changed, 11 insertions, 11 deletions
diff --git a/package/supervisor/supervisor.mk b/package/supervisor/supervisor.mk
index 40ad8ce3a9..d2d58e2c85 100644
--- a/package/supervisor/supervisor.mk
+++ b/package/supervisor/supervisor.mk
@@ -7,19 +7,19 @@
SUPERVISOR_VERSION = 3.0a12
SUPERVISOR_SITE = http://pypi.python.org/packages/source/s/supervisor/
SUPERVISOR_LICENSE_FILES = LICENSES.txt
+SUPERVISOR_SETUP_TYPE = setuptools
-SUPERVISOR_DEPENDENCIES = python host-python-setuptools
-
-define SUPERVISOR_BUILD_CMDS
- (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+define SUPERVISOR_INSTALL_CONF_FILES
+ $(INSTALL) -d -m 755 $(TARGET_DIR)/etc/supervisor.d
+ $(INSTALL) -D -m 644 package/supervisor/supervisord.conf \
+ $(TARGET_DIR)/etc/supervisord.conf
endef
-define SUPERVISOR_INSTALL_TARGET_CMDS
- (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=/usr --root=$(TARGET_DIR))
- sed -i '1s|#!.*python.*|#!/usr/bin/env python|' $(TARGET_DIR)/usr/bin/{echo_supervisord_conf,pidproxy,supervisorctl,supervisord}
- $(INSTALL) -d -m 755 $(TARGET_DIR)/etc/supervisor.d
- $(INSTALL) -D -m 644 package/supervisor/supervisord.conf $(TARGET_DIR)/etc/supervisord.conf
- $(INSTALL) -m 755 package/supervisor/S99supervisord $(TARGET_DIR)/etc/init.d/S99supervisord
+SUPERVISOR_POST_INSTALL_TARGET_HOOKS += SUPERVISOR_INSTALL_CONF_FILES
+
+define SUPERVISOR_INSTALL_INIT_SYSV
+ $(INSTALL) -D -m 755 package/supervisor/S99supervisord \
+ $(TARGET_DIR)/etc/init.d/S99supervisord
endef
-$(eval $(generic-package))
+$(eval $(python-package))
OpenPOWER on IntegriCloud