summaryrefslogtreecommitdiffstats
path: root/package/rsh-redone
diff options
context:
space:
mode:
Diffstat (limited to 'package/rsh-redone')
-rw-r--r--package/rsh-redone/Config.in20
-rw-r--r--package/rsh-redone/rsh-redone.mk8
2 files changed, 20 insertions, 8 deletions
diff --git a/package/rsh-redone/Config.in b/package/rsh-redone/Config.in
index 5a9036278e..d26ca2baeb 100644
--- a/package/rsh-redone/Config.in
+++ b/package/rsh-redone/Config.in
@@ -16,15 +16,23 @@ if BR2_PACKAGE_RSH_REDONE
config BR2_PACKAGE_RSH_REDONE_RLOGIN
bool "rlogin"
-# requires PAM
-#config BR2_PACKAGE_RSH_REDONE_RLOGIND
-# bool "rlogind"
+config BR2_PACKAGE_RSH_REDONE_RLOGIND
+ bool "rlogind"
+ select BR2_PACKAGE_LINUX_PAM
+ depends on BR2_ENABLE_LOCALE && BR2_USE_WCHAR
+
+comment "rlogind needs a toolchain w/ wchar, locale"
+ depends on !(BR2_ENABLE_LOCALE && BR2_USE_WCHAR)
config BR2_PACKAGE_RSH_REDONE_RSH
bool "rsh"
-# requires PAM
-#config BR2_PACKAGE_RSH_REDONE_RSHD
-# bool "rshd"
+config BR2_PACKAGE_RSH_REDONE_RSHD
+ bool "rshd"
+ select BR2_PACKAGE_LINUX_PAM
+ depends on BR2_ENABLE_LOCALE && BR2_USE_WCHAR
+
+comment "rshd needs a toolchain w/ wchar, locale"
+ depends on !(BR2_ENABLE_LOCALE && BR2_USE_WCHAR)
endif
diff --git a/package/rsh-redone/rsh-redone.mk b/package/rsh-redone/rsh-redone.mk
index c7d3b7ad39..93e1358b66 100644
--- a/package/rsh-redone/rsh-redone.mk
+++ b/package/rsh-redone/rsh-redone.mk
@@ -13,8 +13,12 @@ rsh-redone-bin-$(BR2_PACKAGE_RSH_REDONE_RCP) += rcp
rsh-redone-bin-$(BR2_PACKAGE_RSH_REDONE_RLOGIN) += rlogin
rsh-redone-bin-$(BR2_PACKAGE_RSH_REDONE_RSH) += rsh
rsh-redone-sbin-y =
-rsh-redone-sbin-$(BR2_PACKAGE_RSH_REDONE_RLOGIND) += rlogind
-rsh-redone-sbin-$(BR2_PACKAGE_RSH_REDONE_RSHD) += rshd
+rsh-redone-sbin-$(BR2_PACKAGE_RSH_REDONE_RLOGIND) += in.rlogind
+rsh-redone-sbin-$(BR2_PACKAGE_RSH_REDONE_RSHD) += in.rshd
+
+ifneq ($(BR2_PACKAGE_RSH_REDONE_RSHD)$(BR2_PACKAGE_RSH_REDONE_RLOGIND),)
+RSH_REDONE_DEPENDENCIES = linux-pam
+endif
define RSH_REDONE_BUILD_CMDS
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) BIN="$(rsh-redone-bin-y)" SBIN="$(rsh-redone-sbin-y)"
OpenPOWER on IntegriCloud