summaryrefslogtreecommitdiffstats
path: root/package/pkg-utils.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/pkg-utils.mk')
-rw-r--r--package/pkg-utils.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index 851575c547..51dd7384ba 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -59,8 +59,8 @@ endef
# pkgdir macro is carefully written to handle the case of the Linux
# package, for which the package directory is an empty string.
pkgdir = $(dir $(lastword $(MAKEFILE_LIST)))
-pkgname = $(lastword $(subst /, ,$(call pkgdir)))
-pkgparentdir = $(patsubst %$(call pkgname)/,%,$(call pkgdir))
+pkgname = $(lastword $(subst /, ,$(pkgdir)))
+pkgparentdir = $(patsubst %$(pkgname)/,%,$(pkgdir))
# Define extractors for different archive suffixes
INFLATE.bz2 = $(BZCAT)
OpenPOWER on IntegriCloud