summaryrefslogtreecommitdiffstats
path: root/package/libhttpparser/0001-Use-f-option-when-calling-ln-at-install-time.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/libhttpparser/0001-Use-f-option-when-calling-ln-at-install-time.patch')
-rw-r--r--package/libhttpparser/0001-Use-f-option-when-calling-ln-at-install-time.patch30
1 files changed, 17 insertions, 13 deletions
diff --git a/package/libhttpparser/0001-Use-f-option-when-calling-ln-at-install-time.patch b/package/libhttpparser/0001-Use-f-option-when-calling-ln-at-install-time.patch
index df166565f9..70f16f662f 100644
--- a/package/libhttpparser/0001-Use-f-option-when-calling-ln-at-install-time.patch
+++ b/package/libhttpparser/0001-Use-f-option-when-calling-ln-at-install-time.patch
@@ -8,28 +8,32 @@ This allows "make install; make install" to work properly.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Renaud AUBIN <root@renaud.io>
---
- Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
+ Makefile | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/Makefile b/Makefile
-index 33c8ba0..b36d95a 100644
+index 6cf63bd..c182e5c 100644
--- a/Makefile
+++ b/Makefile
-@@ -125,12 +125,12 @@ tags: http_parser.c http_parser.h test.c
+@@ -133,14 +133,14 @@ tags: http_parser.c http_parser.h test.c
install: library
- $(INSTALL) -D http_parser.h $(INCLUDEDIR)/http_parser.h
- $(INSTALL) -D $(SONAME) $(LIBDIR)/$(SONAME)
-- ln -s $(LIBDIR)/$(SONAME) $(LIBDIR)/libhttp_parser.$(SOEXT)
-+ ln -sf $(LIBDIR)/$(SONAME) $(LIBDIR)/libhttp_parser.$(SOEXT)
+ $(INSTALL) -D http_parser.h $(DESTDIR)$(INCLUDEDIR)/http_parser.h
+ $(INSTALL) -D $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
+- ln -s $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
+- ln -s $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SOLIBNAME).$(SOEXT)
++ ln -sf $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
++ ln -sf $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SOLIBNAME).$(SOEXT)
install-strip: library
- $(INSTALL) -D http_parser.h $(INCLUDEDIR)/http_parser.h
- $(INSTALL) -D -s $(SONAME) $(LIBDIR)/$(SONAME)
-- ln -s $(LIBDIR)/$(SONAME) $(LIBDIR)/libhttp_parser.$(SOEXT)
-+ ln -sf $(LIBDIR)/$(SONAME) $(LIBDIR)/libhttp_parser.$(SOEXT)
+ $(INSTALL) -D http_parser.h $(DESTDIR)$(INCLUDEDIR)/http_parser.h
+ $(INSTALL) -D -s $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
+- ln -s $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
+- ln -s $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SOLIBNAME).$(SOEXT)
++ ln -sf $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
++ ln -sf $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SOLIBNAME).$(SOEXT)
uninstall:
- rm $(INCLUDEDIR)/http_parser.h
+ rm $(DESTDIR)$(INCLUDEDIR)/http_parser.h
--
2.6.2
OpenPOWER on IntegriCloud