summaryrefslogtreecommitdiffstats
path: root/package/boost
diff options
context:
space:
mode:
Diffstat (limited to 'package/boost')
-rw-r--r--package/boost/Config.in5
-rw-r--r--package/boost/boost.mk4
2 files changed, 7 insertions, 2 deletions
diff --git a/package/boost/Config.in b/package/boost/Config.in
index edffd7e351..cffaf6e0e9 100644
--- a/package/boost/Config.in
+++ b/package/boost/Config.in
@@ -67,11 +67,12 @@ config BR2_PACKAGE_BOOST_CONTAINER
# see
# http://www.boost.org/doc/libs/1_59_0/libs/context/doc/html/context/architectures.html
-# for the list of supported architectures.
+# for the list of supported architectures. Sparc pretends to be
+# supported, but it doesn't build.
config BR2_PACKAGE_BOOST_CONTEXT
bool "boost-context"
depends on (BR2_arm || BR2_armeb || BR2_i386 || BR2_mips || BR2_mipsel \
- || BR2_powerpc || BR2_sparc || BR2_x86_64)
+ || BR2_powerpc || BR2_x86_64)
config BR2_PACKAGE_BOOST_COROUTINE
bool "boost-coroutine"
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index efc0020fe2..178f7b8738 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -89,6 +89,10 @@ BOOST_OPTS += toolset=gcc \
abi=$(BOOST_ABI) \
variant=$(if $(BR2_ENABLE_DEBUG),debug,release)
+ifeq ($(BR2_sparc64),y)
+BOOST_OPTS += architecture=sparc instruction-set=ultrasparc
+endif
+
ifeq ($(BR2_sparc),y)
BOOST_OPTS += architecture=sparc instruction-set=v8
endif
OpenPOWER on IntegriCloud