summaryrefslogtreecommitdiffstats
path: root/package/avahi
diff options
context:
space:
mode:
Diffstat (limited to 'package/avahi')
-rw-r--r--package/avahi/Config.in8
-rw-r--r--package/avahi/avahi.mk14
2 files changed, 22 insertions, 0 deletions
diff --git a/package/avahi/Config.in b/package/avahi/Config.in
index 483d976c77..b52cc78ce5 100644
--- a/package/avahi/Config.in
+++ b/package/avahi/Config.in
@@ -35,6 +35,14 @@ config BR2_PACKAGE_AVAHI_DAEMON
The daemon registers local IP addresses and services using
mDNS/DNS-SD.
+config BR2_PACKAGE_AVAHI_LIBDNSSD_COMPATIBILITY
+ bool "libdns_sd compatibility (Bonjour)"
+ depends on BR2_PACKAGE_AVAHI_DAEMON
+ select BR2_PACKAGE_DBUS
+ help
+ Enable the libdns_sd (Bonjour) compatibility library support
+ for legacy applications.
+
endif
comment "avahi needs a toolchain w/ threads"
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index 08364dfa22..55527dcde7 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -101,6 +101,10 @@ else
AVAHI_CONF_OPT += --with-xml=none
endif
+ifeq ($(BR2_PACKAGE_AVAHI_LIBDNSSD_COMPATIBILITY),y)
+AVAHI_CONF_OPT += --enable-compat-libdns_sd
+endif
+
ifeq ($(BR2_PACKAGE_DBUS),y)
AVAHI_DEPENDENCIES += dbus
else
@@ -181,4 +185,14 @@ endef
endif
+# applications expects to be able to #include <dns_sd.h>
+define AVAHI_STAGING_INSTALL_LIBDNSSD_LINK
+ ln -sf avahi-compat-libdns_sd/dns_sd.h \
+ $(STAGING_DIR)/usr/include/dns_sd.h
+endef
+
+ifeq ($(BR2_PACKAGE_AVAHI_LIBDNSSD_COMPATIBILITY),y)
+AVAHI_POST_INSTALL_STAGING_HOOKS += AVAHI_STAGING_INSTALL_LIBDNSSD_LINK
+endif
+
$(eval $(autotools-package))
OpenPOWER on IntegriCloud