summaryrefslogtreecommitdiffstats
path: root/package/aiccu
diff options
context:
space:
mode:
Diffstat (limited to 'package/aiccu')
-rw-r--r--package/aiccu/aiccu-0002-makefile-reorder-linked-libraries.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/aiccu/aiccu-0002-makefile-reorder-linked-libraries.patch b/package/aiccu/aiccu-0002-makefile-reorder-linked-libraries.patch
new file mode 100644
index 0000000000..cc189b29c6
--- /dev/null
+++ b/package/aiccu/aiccu-0002-makefile-reorder-linked-libraries.patch
@@ -0,0 +1,24 @@
+Makefile: changed LDFLAGS contents and order on the compile line for --static
+
+Signed-off-by: Michael Rommel <rommel@layer-7.net>
+
+--- aiccu_20070115.orig/unix-console/Makefile 2007-01-15 12:04:27.000000000 +0100
++++ aiccu_20070115/unix-console/Makefile 2013-09-29 22:54:42.742963861 +0200
+@@ -42,7 +42,7 @@ CFLAGS += -D AICCU_CONSOLE
+ # Currently defaultly builds only on Linux, but other platforms might easily also support it
+ ifeq ($(shell uname | grep -c "Linux"),1)
+ CFLAGS += -D AICCU_GNUTLS
+-LDFLAGS += -lgnutls
++LDFLAGS += -lgnutls -lhogweed -lnettle -lgmp -lz
+ endif
+
+ # Linux
+@@ -144,7 +144,7 @@ endif
+ all: aiccu
+
+ aiccu: $(OBJS) ${SRCS} ${INCS}
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS)
++ $(CC) $(CFLAGS) -o $@ $(OBJS) $(LDFLAGS)
+ ifeq ($(shell echo $(CFLAGS) | grep -c "DEBUG"),0)
+ ifeq ($(shell echo "$(RPM_OPT_FLAGS)" | wc -c),1)
+ strip $@
OpenPOWER on IntegriCloud