summaryrefslogtreecommitdiffstats
path: root/boot/uboot
diff options
context:
space:
mode:
Diffstat (limited to 'boot/uboot')
-rw-r--r--boot/uboot/Config.in14
-rw-r--r--boot/uboot/uboot.mk3
2 files changed, 17 insertions, 0 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index c33861bac6..004f9c0ff0 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -407,4 +407,18 @@ config BR2_TARGET_UBOOT_ENVIMAGE_REDUNDANT
endif # BR2_TARGET_UBOOT_ENVIMAGE
+if BR2_TARGET_UBOOT_BUILD_SYSTEM_KCONFIG
+
+config BR2_TARGET_UBOOT_CUSTOM_DTS_PATH
+ string "Device Tree Source file paths"
+ help
+ Space-separated list of paths to device tree source files
+ that will be copied to arch/ARCH/dts/ before starting the
+ build.
+
+ To use this device tree source file, the U-Boot configuration
+ file must refer to it.
+
+endif
+
endif # BR2_TARGET_UBOOT
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index aac692c47f..1d464d9675 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -195,6 +195,9 @@ endef
endif # BR2_TARGET_UBOOT_BUILD_SYSTEM_LEGACY
define UBOOT_BUILD_CMDS
+ $(if $(BR2_TARGET_UBOOT_CUSTOM_DTS_PATH),
+ cp -f $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_DTS_PATH)) $(@D)/arch/$(UBOOT_ARCH)/dts/
+ )
$(TARGET_CONFIGURE_OPTS) \
$(MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) \
$(UBOOT_MAKE_TARGET)
OpenPOWER on IntegriCloud