summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rwxr-xr-xsupport/scripts/generate-gitlab-ci-yml17
2 files changed, 18 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 37df98520e..c5b78b3274 100644
--- a/Makefile
+++ b/Makefile
@@ -1152,9 +1152,7 @@ check-package:
.PHONY: .gitlab-ci.yml
.gitlab-ci.yml: .gitlab-ci.yml.in
- cp $< $@
- (cd configs; LC_ALL=C ls -1 *_defconfig) | sed 's/$$/: *defconfig/' >> $@
- set -o pipefail; ./support/testing/run-tests -l 2>&1 | sed -r -e '/^test_run \((.*)\).*/!d; s//\1: *runtime_test/' | LC_ALL=C sort >> $@
+ ./support/scripts/generate-gitlab-ci-yml $< > $@
include docs/manual/manual.mk
-include $(foreach dir,$(BR2_EXTERNAL_DIRS),$(sort $(wildcard $(dir)/docs/*/*.mk)))
diff --git a/support/scripts/generate-gitlab-ci-yml b/support/scripts/generate-gitlab-ci-yml
new file mode 100755
index 0000000000..431911d370
--- /dev/null
+++ b/support/scripts/generate-gitlab-ci-yml
@@ -0,0 +1,17 @@
+#!/usr/bin/env bash
+set -e
+set -o pipefail
+
+input="${1}"
+
+cat "${input}"
+
+(
+ cd configs
+ LC_ALL=C ls -1 *_defconfig
+) \
+ | sed 's/$/: *defconfig/'
+
+./support/testing/run-tests -l 2>&1 \
+ | sed -r -e '/^test_run \((.*)\).*/!d; s//\1: *runtime_test/' \
+ | LC_ALL=C sort
OpenPOWER on IntegriCloud