summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/wpa_supplicant/Config.in21
-rw-r--r--package/wpa_supplicant/wpa_supplicant.mk2
2 files changed, 22 insertions, 1 deletions
diff --git a/package/wpa_supplicant/Config.in b/package/wpa_supplicant/Config.in
index f32a867489..eb42257000 100644
--- a/package/wpa_supplicant/Config.in
+++ b/package/wpa_supplicant/Config.in
@@ -8,6 +8,27 @@ config BR2_PACKAGE_WPA_SUPPLICANT
if BR2_PACKAGE_WPA_SUPPLICANT
+config BR2_PACKAGE_WPA_SUPPLICANT_NL80211
+ bool "Enable nl80211 support"
+ default y
+ select BR2_PACKAGE_LIBNL
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libnl
+ help
+ Enable support for nl80211. This is the current wireless
+ API for Linux, supported by all wireless drivers in vanilla
+ Linux, but may not be supported by some out-of-tree Linux
+ wireless drivers. wpa_supplicant will still fall back to
+ using the Wireless Extensions (wext) API with these drivers.
+
+ If this option is disabled, then only the deprecated wext
+ API will be supported, with far less features. Linux may
+ supports using wext with modern drivers using a
+ compatibility layer, but it must be enabled in the kernel
+ configuration.
+
+comment "nl80211 support needs a toolchain w/ threads"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS
+
config BR2_PACKAGE_WPA_SUPPLICANT_AP_SUPPORT
bool "Enable AP mode"
help
diff --git a/package/wpa_supplicant/wpa_supplicant.mk b/package/wpa_supplicant/wpa_supplicant.mk
index 1a3e0dbb47..0574f02f41 100644
--- a/package/wpa_supplicant/wpa_supplicant.mk
+++ b/package/wpa_supplicant/wpa_supplicant.mk
@@ -32,7 +32,7 @@ WPA_SUPPLICANT_CONFIG_DISABLE = \
# libnl-3 needs -lm (for rint) and -lpthread if linking statically
# And library order matters hence stick -lnl-3 first since it's appended
# in the wpa_supplicant Makefiles as in LIBS+=-lnl-3 ... thus failing
-ifeq ($(BR2_PACKAGE_LIBNL),y)
+ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_NL80211),y)
ifeq ($(BR2_STATIC_LIBS),y)
WPA_SUPPLICANT_LIBS += -lnl-3 -lm -lpthread
endif
OpenPOWER on IntegriCloud