summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile10
-rw-r--r--docs/manual/how-buildroot-works.txt9
2 files changed, 8 insertions, 11 deletions
diff --git a/Makefile b/Makefile
index ae868dae27..2b1391740a 100644
--- a/Makefile
+++ b/Makefile
@@ -301,9 +301,7 @@ GNU_HOST_NAME:=$(shell support/gnuconfig/config.guess)
#
################################################################################
-BASE_TARGETS = toolchain
-
-TARGETS:=
+TARGETS:= toolchain
# silent mode requested?
QUIET:=$(if $(findstring s,$(MAKEFLAGS)),-q)
@@ -412,7 +410,7 @@ endif
include fs/common.mk
-TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS) $(BASE_TARGETS))
+TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS))
TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
# host-* dependencies have to be handled specially, as those aren't
@@ -434,7 +432,7 @@ HOST_DEPS = $(sort $(foreach dep,\
HOST_SOURCE += $(addsuffix -source,$(sort $(TARGETS_HOST_DEPS) $(HOST_DEPS)))
TARGETS_LEGAL_INFO:=$(patsubst %,%-legal-info,\
- $(TARGETS) $(BASE_TARGETS) $(TARGETS_HOST_DEPS) $(HOST_DEPS))))
+ $(TARGETS) $(TARGETS_HOST_DEPS) $(HOST_DEPS))))
dirs: $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
$(HOST_DIR) $(BINARIES_DIR) $(STAMP_DIR)
@@ -453,7 +451,7 @@ world: target-post-image
.PHONY: all world toolchain dirs clean distclean source outputmakefile \
legal-info legal-info-prepare legal-info-clean printvars \
target-finalize target-post-image \
- $(BASE_TARGETS) $(TARGETS) $(TARGETS_ROOTFS) \
+ $(TARGETS) $(TARGETS_ROOTFS) \
$(TARGETS_DIRCLEAN) $(TARGETS_SOURCE) $(TARGETS_LEGAL_INFO) \
$(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
$(HOST_DIR) $(BINARIES_DIR) $(STAMP_DIR)
diff --git a/docs/manual/how-buildroot-works.txt b/docs/manual/how-buildroot-works.txt
index 68ddd13793..a96e45b0fe 100644
--- a/docs/manual/how-buildroot-works.txt
+++ b/docs/manual/how-buildroot-works.txt
@@ -56,11 +56,10 @@ configuration is done):
+stamps+, etc. in the output directory (+output/+ by default,
another value can be specified using +O=+)
-* Generate all the targets listed in the +BASE_TARGETS+ variable. When
- an internal toolchain is used, this means generating the
- cross-compilation toolchain. When an external toolchain is used,
- this means checking the features of the external toolchain and
- importing it into the Buildroot environment.
+* Generate the toolchain target. When an internal toolchain is used, this
+ means generating the cross-compilation toolchain. When an external
+ toolchain is used, this means checking the features of the external
+ toolchain and importing it into the Buildroot environment.
* Generate all the targets listed in the +TARGETS+ variable. This
variable is filled by all the individual components'
OpenPOWER on IntegriCloud