summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/pkg-download.mk3
-rwxr-xr-xsupport/download/check-hash6
2 files changed, 9 insertions, 0 deletions
diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index e274712515..1fc23c4b34 100644
--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -60,6 +60,9 @@ domainseparator = $(if $(1),$(1),/)
# github(user,package,version): returns site of GitHub repository
github = https://github.com/$(1)/$(2)/archive/$(3)
+# Expressly do not check hashes for those files
+export BR_NO_CHECK_HASH_FOR
+
################################################################################
# The DOWNLOAD_* helpers are in charge of getting a working copy
# of the source repository for their corresponding SCM,
diff --git a/support/download/check-hash b/support/download/check-hash
index 678a7ef934..6b0372e3ed 100755
--- a/support/download/check-hash
+++ b/support/download/check-hash
@@ -99,6 +99,12 @@ while read t h f; do
done <"${h_file}"
if [ ${nb_checks} -eq 0 ]; then
+ case " ${BR_NO_CHECK_HASH_FOR} " in
+ *" ${base} "*)
+ # File explicitly has no hash
+ exit 0
+ ;;
+ esac
printf "ERROR: No hash found for %s\n" "${base}" >&2
exit 0
fi
OpenPOWER on IntegriCloud