summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorYugendra Sai Babu Nadupuru <yugendra.sai.babu.nadupuru@rockwellcollins.com>2016-07-14 16:08:02 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-15 13:11:06 +0200
commitc091ecda8743683102f9cccffa15f10b55b52ef3 (patch)
tree3284728963d5646c200a918b887535419bab6a4b /package
parent7ce32aa271fd7e9e72bbef6119be038e834c677a (diff)
downloadbuildroot-c091ecda8743683102f9cccffa15f10b55b52ef3.tar.gz
buildroot-c091ecda8743683102f9cccffa15f10b55b52ef3.zip
ntp: add support for SHM clocks
In order for gpsd to work with the new version of ntpd, an enable option must be added to the configure step of ntp that allows for support of SHM clocks to be attached through shared memory. Signed-off-by: Yugendra Sai Babu Nadupuru <yugendra.sai.babu.nadupuru@rockwellcollins.com> Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/ntp/Config.in6
-rw-r--r--package/ntp/ntp.mk6
2 files changed, 12 insertions, 0 deletions
diff --git a/package/ntp/Config.in b/package/ntp/Config.in
index 1763225f44..8ce9a5b0bb 100644
--- a/package/ntp/Config.in
+++ b/package/ntp/Config.in
@@ -19,6 +19,12 @@ config BR2_PACKAGE_NTP_NTP_KEYGEN
help
Create a NTP host key
+config BR2_PACKAGE_NTP_NTP_SHM_CLK
+ bool "SHM clock support"
+ help
+ Compile ntp with support for a SHM clock attached through
+ shared memory.
+
config BR2_PACKAGE_NTP_NTP_WAIT
bool "ntp-wait"
depends on BR2_PACKAGE_PERL
diff --git a/package/ntp/ntp.mk b/package/ntp/ntp.mk
index 8d3a6f31f3..7d203a5e37 100644
--- a/package/ntp/ntp.mk
+++ b/package/ntp/ntp.mk
@@ -42,6 +42,12 @@ else
NTP_CONF_OPTS += --disable-ATOM
endif
+ifeq ($(BR2_PACKAGE_NTP_NTP_SHM_CLK),y)
+NTP_CONF_OPTS += --enable-SHM
+else
+NTP_CONF_OPTS += --disable-SHM
+endif
+
NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_NTP_KEYGEN) += util/ntp-keygen
NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_NTP_WAIT) += scripts/ntp-wait/ntp-wait
NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_NTPDATE) += ntpdate/ntpdate
OpenPOWER on IntegriCloud