summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2017-07-12 22:37:03 +0300
committerPeter Korsgaard <peter@korsgaard.com>2017-07-15 17:49:28 +0200
commitde660718500e6c15d6b3ae5d7faf6cdf9dd9ebc7 (patch)
treea898509a27113476ad4d0c8ad4d5ceec29dec0b9 /package
parent7d44e53b9515b99e636bdcf863c0ae92c552c29b (diff)
downloadbuildroot-de660718500e6c15d6b3ae5d7faf6cdf9dd9ebc7.tar.gz
buildroot-de660718500e6c15d6b3ae5d7faf6cdf9dd9ebc7.zip
git: fix build with NLS disabled
Since commit bbfb02598bf75 (git: use the new gettext logic) host-gettext is no longer an unconditional dependency of git. When NLS is disabled host-gettext is not built. This breaks the build of git, because the git Makefile runs msgfmt unless NO_GETTEXT is defined. Define NO_GETTEXT when NLS is disabled to fix the build. Fixes: http://autobuild.buildroot.net/results/c87/c8717619a1307f21cb9fe61196511cea44f72015/ http://autobuild.buildroot.net/results/e7a/e7acff51f988c333c3fe0c4a18eed42a273932d3/ http://autobuild.buildroot.net/results/153/153b17959847ec2079883c087cee27afbdf9571e/ Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Sagaert Johan <sagaert.johan@skynet.be> Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package')
-rw-r--r--package/git/git.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/git/git.mk b/package/git/git.mk
index 23ace0fd48..52907a27b7 100644
--- a/package/git/git.mk
+++ b/package/git/git.mk
@@ -57,6 +57,12 @@ else
GIT_CONF_OPTS += --without-tcltk
endif
+ifeq ($(BR2_SYSTEM_ENABLE_NLS),)
+GIT_MAKE_OPTS = NO_GETTEXT=1
+endif
+
+GIT_INSTALL_TARGET_OPTS = $(GIT_MAKE_OPTS) DESTDIR=$(TARGET_DIR) install
+
# assume yes for these tests, configure will bail out otherwise
# saying error: cannot run test program while cross compiling
GIT_CONF_ENV += \
OpenPOWER on IntegriCloud