summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFloris Bos <bos@je-eigen-domein.nl>2015-05-01 20:12:33 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-05-02 09:44:10 +0200
commit8eeb14578679f956e7902b0dd0d0c41336ca39f9 (patch)
tree6cd2716091b0205bb81c417ace3c422ac4e5d11c /package
parente3526c15194eab9b3ef8d7ce3dc032a1290658fa (diff)
downloadbuildroot-8eeb14578679f956e7902b0dd0d0c41336ca39f9.tar.gz
buildroot-8eeb14578679f956e7902b0dd0d0c41336ca39f9.zip
php: fpm sapi: install startup script
Install the startup script if using the FastCGI Process Manager. Signed-off-by: Floris Bos <bos@je-eigen-domein.nl> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/php/0006-fix-php-fpm.service.in.patch35
-rw-r--r--package/php/php.mk15
2 files changed, 50 insertions, 0 deletions
diff --git a/package/php/0006-fix-php-fpm.service.in.patch b/package/php/0006-fix-php-fpm.service.in.patch
new file mode 100644
index 0000000000..a182a2528b
--- /dev/null
+++ b/package/php/0006-fix-php-fpm.service.in.patch
@@ -0,0 +1,35 @@
+From bb19125781c0794da9a63fee62e263ff4efff661 Mon Sep 17 00:00:00 2001
+From: Floris Bos <bos@je-eigen-domein.nl>
+Date: Fri, 1 May 2015 15:28:55 +0200
+Subject: [PATCH] Fix php-fpm.service.in
+
+- Expand file paths.
+- Remove obsolete After=syslog.target. Syslog is socket activated nowadays.
+
+Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
+---
+ sapi/fpm/php-fpm.service.in | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/sapi/fpm/php-fpm.service.in b/sapi/fpm/php-fpm.service.in
+index a2df30e..c135f04 100644
+--- a/sapi/fpm/php-fpm.service.in
++++ b/sapi/fpm/php-fpm.service.in
+@@ -1,11 +1,11 @@
+ [Unit]
+ Description=The PHP FastCGI Process Manager
+-After=syslog.target network.target
++After=network.target
+
+ [Service]
+ Type=@php_fpm_systemd@
+-PIDFile=@localstatedir@/run/php-fpm.pid
+-ExecStart=@sbindir@/php-fpm --nodaemonize --fpm-config @sysconfdir@/php-fpm.conf
++PIDFile=@EXPANDED_LOCALSTATEDIR@/run/php-fpm.pid
++ExecStart=@EXPANDED_SBINDIR@/php-fpm --nodaemonize --fpm-config @EXPANDED_SYSCONFDIR@/php-fpm.conf
+ ExecReload=/bin/kill -USR2 $MAINPID
+
+ [Install]
+--
+2.1.4
+
diff --git a/package/php/php.mk b/package/php/php.mk
index e4331f2c16..4c65c35f71 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -251,6 +251,21 @@ PHP_CONF_OPTS += \
PHP_DEPENDENCIES += jpeg libpng freetype
endif
+ifeq ($(BR2_PACKAGE_PHP_FPM),y)
+define PHP_INSTALL_INIT_SYSV
+ $(INSTALL) -D -m 0755 $(@D)/sapi/fpm/init.d.php-fpm \
+ $(TARGET_DIR)/etc/init.d/S49php-fpm
+endef
+
+define PHP_INSTALL_INIT_SYSTEMD
+ $(INSTALL) -D -m 0644 $(@D)/sapi/fpm/php-fpm.service \
+ $(TARGET_DIR)/usr/lib/systemd/system/php-fpm.service
+ mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
+ ln -fs ../../../../usr/lib/systemd/system/php-fpm.service \
+ $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/php-fpm.service
+endef
+endif
+
define PHP_EXTENSIONS_FIXUP
$(SED) "/prefix/ s:/usr:$(STAGING_DIR)/usr:" \
$(STAGING_DIR)/usr/bin/phpize
OpenPOWER on IntegriCloud