summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-05 23:43:12 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 23:00:16 +0100
commit4a3b3a8ba5ef719d4aaee84b6d7ed9bb07663804 (patch)
tree854aa57b694203c1abaea27bcc17733ace5eda65 /package
parent89d210449c7c410ddc8524b595b070f425d515af (diff)
downloadbuildroot-4a3b3a8ba5ef719d4aaee84b6d7ed9bb07663804.tar.gz
buildroot-4a3b3a8ba5ef719d4aaee84b6d7ed9bb07663804.zip
package/pound: new package
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> [Thomas: pass --with-owner/--with-group instead of SEDing the Makefile.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/Config.in1
-rw-r--r--package/pound/Config.in18
-rw-r--r--package/pound/pound.hash2
-rw-r--r--package/pound/pound.mk24
4 files changed, 45 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index c0b3b177e9..23fd62c07a 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1448,6 +1448,7 @@ endif
source "package/p910nd/Config.in"
source "package/phidgetwebservice/Config.in"
source "package/portmap/Config.in"
+ source "package/pound/Config.in"
source "package/pppd/Config.in"
source "package/pptp-linux/Config.in"
source "package/privoxy/Config.in"
diff --git a/package/pound/Config.in b/package/pound/Config.in
new file mode 100644
index 0000000000..91c29ea7a6
--- /dev/null
+++ b/package/pound/Config.in
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_POUND
+ bool "pound"
+ depends on !BR2_STATIC_LIBS
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on BR2_USE_MMU # fork()
+ select BR2_PACKAGE_OPENSSL
+ help
+ The Pound program is a reverse proxy, load balancer and HTTPS
+ front-end for Web server(s). Pound was developed to enable
+ distributing the load among several Web-servers and to allow
+ for a convenient SSL wrapper for those Web servers that do not
+ offer it natively.
+
+ http://www.apsis.ch/pound
+
+comment "pound needs a toolchain w/ dynamic library, threads"
+ depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
+ depends on BR2_USE_MMU
diff --git a/package/pound/pound.hash b/package/pound/pound.hash
new file mode 100644
index 0000000000..6908b9060c
--- /dev/null
+++ b/package/pound/pound.hash
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 cdfbf5a7e8dc8fbbe0d6c1e83cd3bd3f2472160aac65684bb01ef661c626a8e4 Pound-2.7.tgz
diff --git a/package/pound/pound.mk b/package/pound/pound.mk
new file mode 100644
index 0000000000..408664214b
--- /dev/null
+++ b/package/pound/pound.mk
@@ -0,0 +1,24 @@
+################################################################################
+#
+# pound
+#
+################################################################################
+
+POUND_VERSION = 2.7
+POUND_SITE = http://www.apsis.ch/pound
+POUND_SOURCE = Pound-$(POUND_VERSION).tgz
+POUND_LICENSE = GPLv3+
+POUND_LICENSE_FILES = GPL.txt
+POUND_DEPENDENCIES = openssl
+
+# Force owner/group to us, otherwise it will try proxy:proxy by
+# default.
+POUND_CONF_OPTS = \
+ --with-owner=$(shell id -un) \
+ --with-group=$(shell id -gn)
+
+ifeq ($(BR2_PACKAGE_PCRE),y)
+POUND_DEPENDENCIES += pcre
+endif
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud