summaryrefslogtreecommitdiffstats
path: root/package/vpnc/0005-Makefile-allow-passing-a-custom-path-to-libgcrypt-co.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-10 23:40:23 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-06-03 16:12:26 +0200
commitb989436447d7e518d52517ebb7792af3736e1a79 (patch)
treea6687e0ae09affb8df3f0d54872a0cecc90dbbc2 /package/vpnc/0005-Makefile-allow-passing-a-custom-path-to-libgcrypt-co.patch
parent88437f6feb15b4db53ba10215141477052361e79 (diff)
downloadbuildroot-b989436447d7e518d52517ebb7792af3736e1a79.tar.gz
buildroot-b989436447d7e518d52517ebb7792af3736e1a79.zip
vpnc: bump to newer upstream version
While the official upstream has not published any new tarball, they have continued to update their Subversion repository with additional changes. This commit therefore updates the vpnc package to a newer version, using the Github repository that replicates the original Subversion repository. Since the update required some updates to the patches, we took this opportunity to split them in more fine-grained changes, and document them more properly. Consequently: - The patch 0001 that fixes the Makefile gets split into 3 patches, 0001, 0002 and 0003, each for one specific issue. - Patch 0002 to disable building the manpages gets changed into a solution that is potentially upstreamable, and is now patch 0004. - A new patch 0005 is added to specify a custom libgcrypt-config path, since this tool is now used to know how to link with libgcrypt. - The SUSv3 function removal patch is now patch 0006, and gains a better commit log. Also, this vpnc version now depends on gnutls, which basically is a better replacement for OpenSSL, whose support was not enabled by default due to licensing issues (vpnc is under the GPL, which isn't compatible with the OpenSSL license). Patches have been submitted upstream: http://lists.unix-ag.uni-kl.de/pipermail/vpnc-devel/2016-June/004186.html Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/vpnc/0005-Makefile-allow-passing-a-custom-path-to-libgcrypt-co.patch')
-rw-r--r--package/vpnc/0005-Makefile-allow-passing-a-custom-path-to-libgcrypt-co.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/package/vpnc/0005-Makefile-allow-passing-a-custom-path-to-libgcrypt-co.patch b/package/vpnc/0005-Makefile-allow-passing-a-custom-path-to-libgcrypt-co.patch
new file mode 100644
index 0000000000..86239079a5
--- /dev/null
+++ b/package/vpnc/0005-Makefile-allow-passing-a-custom-path-to-libgcrypt-co.patch
@@ -0,0 +1,40 @@
+From 6180ca780e3a792bd632d8899c2b35991822c93d Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Mon, 8 Feb 2016 23:32:57 +0100
+Subject: [PATCH] Makefile: allow passing a custom path to libgcrypt-config
+
+The libgcrypt-config program may not be in the PATH, so this patch
+adjusts the Makefile so that it understands a LIBGCRYPT_CONFIG
+variable. By default, its value is libgcrypt-config so that the
+behavior is unchanged.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+
+ Makefile | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ea2cd41..649ddfb 100644
+--- a/Makefile
++++ b/Makefile
+@@ -61,13 +61,14 @@ BINSRCS = $(addsuffix .c,$(BINS))
+ VERSION ?= $(shell sh mk-version)
+ RELEASE_VERSION := $(shell cat VERSION)
+
++LIBGCRYPT_CONFIG ?= libgcrypt-config
+ CC ?= gcc
+ CFLAGS ?= -O3 -g
+ override CFLAGS += -W -Wall -Wmissing-declarations -Wwrite-strings
+-override CFLAGS += $(shell libgcrypt-config --cflags) $(CRYPTO_CFLAGS)
++override CFLAGS += $(shell $(LIBGCRYPT_CONFIG) --cflags) $(CRYPTO_CFLAGS)
+ override CPPFLAGS += -DVERSION=\"$(VERSION)\"
+ LDFLAGS ?= -g
+-LIBS += $(shell libgcrypt-config --libs) $(CRYPTO_LDADD)
++LIBS += $(shell $(LIBGCRYPT_CONFIG) --libs) $(CRYPTO_LDADD)
+
+ ifeq ($(shell uname -s), SunOS)
+ LIBS += -lnsl -lresolv -lsocket
+--
+2.6.4
+
OpenPOWER on IntegriCloud