summaryrefslogtreecommitdiffstats
path: root/package/supervisor
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-12-11 21:26:55 +0100
committerPeter Korsgaard <peter@korsgaard.com>2013-12-15 13:41:23 +0100
commit0935498a76d4a86d8d998ebb8d42c74af5a26075 (patch)
treeefed44f71ecd99025d9d33bb381c0d354ede795b /package/supervisor
parent8fd5a94562b771b56e1b06d6b3ea9b9a19e1a52a (diff)
downloadbuildroot-0935498a76d4a86d8d998ebb8d42c74af5a26075.tar.gz
buildroot-0935498a76d4a86d8d998ebb8d42c74af5a26075.zip
supervisor: convert to the Python package infrastructure
Remove the select of BR2_PACKAGE_PYTHON_SETUPTOOLS, since what is really needed is host-setuptools (as can be seen from the original .mk file), and not setuptools for the target. Also, remove the mangling of the Python shebang, since it's now done by passing the --executable= option at install time (done in the Python package infrastructure). Finally, convert the package to use <pkg>_INSTALL_INIT_SYSV. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/supervisor')
-rw-r--r--package/supervisor/Config.in1
-rw-r--r--package/supervisor/supervisor.mk22
2 files changed, 11 insertions, 12 deletions
diff --git a/package/supervisor/Config.in b/package/supervisor/Config.in
index 53401810f3..c511dd8705 100644
--- a/package/supervisor/Config.in
+++ b/package/supervisor/Config.in
@@ -1,7 +1,6 @@
config BR2_PACKAGE_SUPERVISOR
bool "supervisor"
depends on BR2_PACKAGE_PYTHON
- select BR2_PACKAGE_PYTHON_SETUPTOOLS
select BR2_PACKAGE_PYTHON_MELD3
help
A client/server system that allows its users to control a
diff --git a/package/supervisor/supervisor.mk b/package/supervisor/supervisor.mk
index 40ad8ce3a9..d2d58e2c85 100644
--- a/package/supervisor/supervisor.mk
+++ b/package/supervisor/supervisor.mk
@@ -7,19 +7,19 @@
SUPERVISOR_VERSION = 3.0a12
SUPERVISOR_SITE = http://pypi.python.org/packages/source/s/supervisor/
SUPERVISOR_LICENSE_FILES = LICENSES.txt
+SUPERVISOR_SETUP_TYPE = setuptools
-SUPERVISOR_DEPENDENCIES = python host-python-setuptools
-
-define SUPERVISOR_BUILD_CMDS
- (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+define SUPERVISOR_INSTALL_CONF_FILES
+ $(INSTALL) -d -m 755 $(TARGET_DIR)/etc/supervisor.d
+ $(INSTALL) -D -m 644 package/supervisor/supervisord.conf \
+ $(TARGET_DIR)/etc/supervisord.conf
endef
-define SUPERVISOR_INSTALL_TARGET_CMDS
- (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=/usr --root=$(TARGET_DIR))
- sed -i '1s|#!.*python.*|#!/usr/bin/env python|' $(TARGET_DIR)/usr/bin/{echo_supervisord_conf,pidproxy,supervisorctl,supervisord}
- $(INSTALL) -d -m 755 $(TARGET_DIR)/etc/supervisor.d
- $(INSTALL) -D -m 644 package/supervisor/supervisord.conf $(TARGET_DIR)/etc/supervisord.conf
- $(INSTALL) -m 755 package/supervisor/S99supervisord $(TARGET_DIR)/etc/init.d/S99supervisord
+SUPERVISOR_POST_INSTALL_TARGET_HOOKS += SUPERVISOR_INSTALL_CONF_FILES
+
+define SUPERVISOR_INSTALL_INIT_SYSV
+ $(INSTALL) -D -m 755 package/supervisor/S99supervisord \
+ $(TARGET_DIR)/etc/init.d/S99supervisord
endef
-$(eval $(generic-package))
+$(eval $(python-package))
OpenPOWER on IntegriCloud