summaryrefslogtreecommitdiffstats
path: root/package/sp-oops-extract/0001-Make-the-Makefile-more-cross-compiler-friendly.patch
diff options
context:
space:
mode:
authorDoug Kehn <rdkehn@yahoo.com>2015-08-18 16:17:52 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-29 23:12:48 +0200
commit22212f15e43e5f274c8c0ad33957a346ccb99cf1 (patch)
tree9676d12c57831f0e481c2be77a4ed9d1da7a5552 /package/sp-oops-extract/0001-Make-the-Makefile-more-cross-compiler-friendly.patch
parent0b22622fecfc35737a7dd3933a7116f7c06cbf8c (diff)
downloadbuildroot-22212f15e43e5f274c8c0ad33957a346ccb99cf1.tar.gz
buildroot-22212f15e43e5f274c8c0ad33957a346ccb99cf1.zip
package/sp-oops-extract: new package
A tool for extracting OOPS/panic logs from MTD. Tested using arm-buildroot-linux-gnueabihf toolchain. [Thomas: - use sp-oops-extract instead of sp_oops_extract as the Config.in prompt and in the .mk file comment - remove @ in front of the build and install commands. - use $(TARGET_CONFIGURE_OPTS) instead of manually passing CC, AR, LD, CFLAGS and LDFLAGS.] Signed-off-by: Doug Kehn <rdkehn@yahoo.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sp-oops-extract/0001-Make-the-Makefile-more-cross-compiler-friendly.patch')
-rw-r--r--package/sp-oops-extract/0001-Make-the-Makefile-more-cross-compiler-friendly.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/sp-oops-extract/0001-Make-the-Makefile-more-cross-compiler-friendly.patch b/package/sp-oops-extract/0001-Make-the-Makefile-more-cross-compiler-friendly.patch
new file mode 100644
index 0000000000..67153c27bc
--- /dev/null
+++ b/package/sp-oops-extract/0001-Make-the-Makefile-more-cross-compiler-friendly.patch
@@ -0,0 +1,22 @@
+Fetch from: https://github.com/Schischu/ptxdist_sh/tree/master/patches/sp-oops-extract-0.0.7
+
+From: Bernhard Walle <walle@corscience.de>
+Date: Wed, 21 Mar 2012 15:55:06 +0100
+Subject: [PATCH] Make the Makefile more cross-compiler friendly
+
+Signed-off-by: Bernhard Walle <walle@corscience.de>
+---
+ src/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index cf5b550..e05eb1f 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -9,4 +9,4 @@ distclean: clean
+ $(RM) $(TARGETS)
+
+ sp-oops-extract: oopslog.c
+- gcc -Wall -s -o $@ $^
++ $(CC) $(LDFLAGS) $(CPPFLAGS) $(CFLAGS) -Wall -o $@ $^
+
OpenPOWER on IntegriCloud