summaryrefslogtreecommitdiffstats
path: root/package/qwt
diff options
context:
space:
mode:
authorDavid PICARD <davepiq@yahoo.fr>2016-03-24 21:19:51 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-25 10:46:28 +0100
commita976ee0dc834c56e67e1c832ded00ce23b5ccdb0 (patch)
tree61cc17889389a9230ec7f029d1a6a3d6fefd19a3 /package/qwt
parentab9aa9b0622ee15960b1c451f221d50852a7752d (diff)
downloadbuildroot-a976ee0dc834c56e67e1c832ded00ce23b5ccdb0.tar.gz
buildroot-a976ee0dc834c56e67e1c832ded00ce23b5ccdb0.zip
package/qwt: add support for Qt5.
This version of Qwt is compatible with both Qt and Qt5. This patch adds the option to compile it for Qt5. Signed-off-by: David Picard <davepiq@yahoo.fr> [Thomas: slightly adjust the OpenGL dependencies.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/qwt')
-rw-r--r--package/qwt/Config.in10
-rw-r--r--package/qwt/qwt.mk3
2 files changed, 10 insertions, 3 deletions
diff --git a/package/qwt/Config.in b/package/qwt/Config.in
index 876d465350..6b394e3bc9 100644
--- a/package/qwt/Config.in
+++ b/package/qwt/Config.in
@@ -1,7 +1,9 @@
config BR2_PACKAGE_QWT
bool "qwt"
- depends on BR2_PACKAGE_QT
+ depends on BR2_PACKAGE_QT || BR2_PACKAGE_QT5
select BR2_PACKAGE_QT_GUI_MODULE if BR2_PACKAGE_QT
+ select BR2_PACKAGE_QT5BASE_GUI if BR2_PACKAGE_QT5
+ select BR2_PACKAGE_QT5BASE_CONCURRENT if BR2_PACKAGE_QT5
help
Qwt is a graphics extension to the Qt GUI application
framework. It provides a 2D plotting widget and more.
@@ -13,14 +15,16 @@ if BR2_PACKAGE_QWT
config BR2_PACKAGE_QWT_SVG
bool "SVG support"
select BR2_PACKAGE_QT_SVG if BR2_PACKAGE_QT
+ select BR2_PACKAGE_QT5SVG if BR2_PACKAGE_QT5
config BR2_PACKAGE_QWT_MATHML
bool "MathML support"
config BR2_PACKAGE_QWT_OPENGL
bool "OpenGL support"
- depends on BR2_PACKAGE_HAS_LIBGLES
- depends on BR2_PACKAGE_HAS_LIBEGL
+ depends on (BR2_PACKAGE_HAS_LIBGLES && BR2_PACKAGE_HAS_LIBEG && BR2_PACKAGE_QT) || \
+ (BR2_PACKAGE_QT5_GL_AVAILABLE && BR2_PACKAGE_QT5)
select BR2_PACKAGE_QT_OPENGL_ES if BR2_PACKAGE_QT
+ select BR2_PACKAGE_QT5BASE_OPENGL_LIB if BR2_PACKAGE_QT5
endif
diff --git a/package/qwt/qwt.mk b/package/qwt/qwt.mk
index 4d481fb90b..594b1412c7 100644
--- a/package/qwt/qwt.mk
+++ b/package/qwt/qwt.mk
@@ -11,6 +11,9 @@ QWT_INSTALL_STAGING = YES
ifeq ($(BR2_PACKAGE_QT),y)
QWT_DEPENDENCIES = qt
QWT_QMAKE = $(QT_QMAKE)
+else ifeq ($(BR2_PACKAGE_QT5),y)
+QWT_DEPENDENCIES += qt5
+QWT_QMAKE = $(QT5_QMAKE)
endif
QWT_LICENSE = LGPLv2.1 with exceptions
OpenPOWER on IntegriCloud