summaryrefslogtreecommitdiffstats
path: root/package/qemu
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-10-08 00:38:14 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-10-12 18:59:37 +0200
commit6fd9a3e864789942fbbd9eee3c31e114fa06f41b (patch)
treed01a30a920a9dbced2fa3d09227e7d494921fdcd /package/qemu
parent68ec49acc7be3cefdbc0cfb8a4ea40c223e8afe0 (diff)
downloadbuildroot-6fd9a3e864789942fbbd9eee3c31e114fa06f41b.tar.gz
buildroot-6fd9a3e864789942fbbd9eee3c31e114fa06f41b.zip
package/qemu: add fine-grained target selection
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/qemu')
-rw-r--r--package/qemu/Config.in21
-rw-r--r--package/qemu/qemu.mk4
2 files changed, 25 insertions, 0 deletions
diff --git a/package/qemu/Config.in b/package/qemu/Config.in
index 96ec301fd7..f29f8489aa 100644
--- a/package/qemu/Config.in
+++ b/package/qemu/Config.in
@@ -31,6 +31,25 @@ if BR2_PACKAGE_QEMU
comment "Emulators selection"
+config BR2_PACKAGE_QEMU_CUSTOM_TARGETS
+ string "Enable specific targets"
+ help
+ Enter here the list of QEMU targets you want to build. For example:
+
+ System emulation | User-land emulation
+ ----------------------+-----------------------
+ i386-softmmu | i386-linux-user
+ arm-softmmu | ppc-linux-user
+ x86_64-softmmu | sparc-bsd-user
+ ... | ...
+
+config QEMU_FOO
+ bool # To break the indentation
+
+if BR2_PACKAGE_QEMU_CUSTOM_TARGETS = ""
+
+comment "... or you can select emulator families to enable, below:"
+
config BR2_PACKAGE_QEMU_SYSTEM
bool "Enable all systems emulation"
help
@@ -43,4 +62,6 @@ config BR2_PACKAGE_QEMU_LINUX_USER
# Note: bsd-user can not be build on Linux
+endif # BR2_PACKAGE_QEMU_CUSTOM_TARGETS == ""
+
endif # BR2_PACKAGE_QEMU
diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
index 9f761455c3..5d9fd48a63 100644
--- a/package/qemu/qemu.mk
+++ b/package/qemu/qemu.mk
@@ -111,6 +111,10 @@ else
QEMU_OPTS += --disable-linux-user
endif
+ifneq ($(call qstrip,$(BR2_PACKAGE_QEMU_CUSTOM_TARGETS)),)
+QEMU_OPTS += --target-list="$(call qstrip,$(BR2_PACKAGE_QEMU_CUSTOM_TARGETS))"
+endif
+
define QEMU_CONFIGURE_CMDS
( cd $(@D); \
LIBS='$(QEMU_LIBS)' \
OpenPOWER on IntegriCloud