summaryrefslogtreecommitdiffstats
path: root/package/python3/0026-Add-an-option-to-disable-openssl-support.patch
diff options
context:
space:
mode:
authorAndrey Smirnov <andrew.smirnov@gmail.com>2017-09-18 15:34:41 -0700
committerPeter Korsgaard <peter@korsgaard.com>2017-09-20 19:53:42 +0200
commit6e6e8d37b549033c9dc2ac21ed600708a890894f (patch)
tree9cf2df0ab3b7c65a506bb179dc211368b46d5ec3 /package/python3/0026-Add-an-option-to-disable-openssl-support.patch
parent847048c58d3639b7646eea1ef17ad42d6a68798d (diff)
downloadbuildroot-6e6e8d37b549033c9dc2ac21ed600708a890894f.tar.gz
buildroot-6e6e8d37b549033c9dc2ac21ed600708a890894f.zip
package/python3: bump to 3.6.2
Bump Python3 version to 3.6.2. Patches dropped: "Support PGEN_FOR_BUILD and FREEZE_IMPORTLIB_FOR_BUILD" Rationale: With commit 9d02f562961efd12d3c8317a10916db7f77330cc, code generation step of building CPython now became explicit (instead of always performed as a part of 'make' invocation) and more granular. We no longer need to use Parser/pgen at all and tricking the build system into using different Programs/_freeze_importlib can be done as a part of recipe. Additional info about the build change can be found at https://bugs.python.org/issue23404 Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com> Tested-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/python3/0026-Add-an-option-to-disable-openssl-support.patch')
-rw-r--r--package/python3/0026-Add-an-option-to-disable-openssl-support.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/python3/0026-Add-an-option-to-disable-openssl-support.patch b/package/python3/0026-Add-an-option-to-disable-openssl-support.patch
new file mode 100644
index 0000000000..065e50620d
--- /dev/null
+++ b/package/python3/0026-Add-an-option-to-disable-openssl-support.patch
@@ -0,0 +1,30 @@
+From 4b001683ad1cb1d90b7c389e67447a250fa9c218 Mon Sep 17 00:00:00 2001
+From: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
+Date: Wed, 22 Feb 2017 17:55:59 -0800
+Subject: [PATCH] Add an option to disable openssl support.
+
+Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
+---
+ configure.ac | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 8e3dded25e..28bcdabd67 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -3160,6 +3160,12 @@ AC_ARG_ENABLE(unicodedata,
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} unicodedata"
+ fi])
+
++AC_ARG_ENABLE(openssl,
++ AS_HELP_STRING([--disable-openssl], [disable openssl support]),
++ [ if test "$enableval" = "no"; then
++ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl _ssl _hashlib"
++ fi])
++
+ AC_SUBST(TK)
+ AC_ARG_ENABLE(tk,
+ AS_HELP_STRING([--disable-tk], [disable tk]),
+--
+2.13.5
+
OpenPOWER on IntegriCloud