summaryrefslogtreecommitdiffstats
path: root/package/python-lxml/python-lxml.mk
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2015-02-10 21:01:08 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-14 09:57:43 +0100
commitc66618c2c97b460a8b845fd4b027073e00238bee (patch)
tree75c7c68451baa96752db7d4ac4bf6027bd396b94 /package/python-lxml/python-lxml.mk
parent96e7bca18bd55a70c7f837949c791af52ba91e7e (diff)
downloadbuildroot-c66618c2c97b460a8b845fd4b027073e00238bee.tar.gz
buildroot-c66618c2c97b460a8b845fd4b027073e00238bee.zip
package/python-lxml: new package
The lxml XML toolkit is a Pythonic binding for the C libraries libxml2 and libxslt. Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> [yann.morin.1998@free.fr: fix staging path; trim dependencies of the host variant] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-lxml/python-lxml.mk')
-rw-r--r--package/python-lxml/python-lxml.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/package/python-lxml/python-lxml.mk b/package/python-lxml/python-lxml.mk
new file mode 100644
index 0000000000..e7222e826e
--- /dev/null
+++ b/package/python-lxml/python-lxml.mk
@@ -0,0 +1,31 @@
+################################################################################
+#
+# python-lxml
+#
+################################################################################
+
+PYTHON_LXML_VERSION = 3.4.1
+PYTHON_LXML_SITE = http://lxml.de/files
+PYTHON_LXML_SOURCE = lxml-$(PYTHON_LXML_VERSION).tgz
+
+# Not including the GPL, because it is used only for the test scripts.
+PYTHON_LXML_LICENSE = BSD-3c, Others
+PYTHON_LXML_LICENSE_FILES = \
+ LICENSES.txt \
+ doc/licenses/BSD.txt \
+ doc/licenses/elementtree.txt \
+ src/lxml/isoschematron/resources/rng/iso-schematron.rng
+
+# python-lxml can use either setuptools, or distutils as a fallback.
+# So, we use setuptools.
+PYTHON_LXML_SETUP_TYPE = setuptools
+
+PYTHON_LXML_DEPENDENCIES = libxml2 libxslt zlib
+
+# python-lxml needs these scripts in order to properly detect libxml2 and
+# libxslt compiler and linker flags
+PYTHON_LXML_BUILD_OPTS = \
+ --with-xslt-config=$(STAGING_DIR)/usr/bin/xslt-config \
+ --with-xml2-config=$(STAGING_DIR)/usr/bin/xml2-config
+
+$(eval $(python-package))
OpenPOWER on IntegriCloud