summaryrefslogtreecommitdiffstats
path: root/package/python-cryptography
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2016-02-08 10:04:21 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-19 23:12:05 +0100
commitfbeeb4c8cb4e44c654ca27db9ae05a83202f4104 (patch)
tree9927be9862f5e91ce9bbd1f6936b6c984f0b9ec6 /package/python-cryptography
parent96a7a3cb7688ff67f02d45f0002c638ee5faadb6 (diff)
downloadbuildroot-fbeeb4c8cb4e44c654ca27db9ae05a83202f4104.tar.gz
buildroot-fbeeb4c8cb4e44c654ca27db9ae05a83202f4104.zip
python-cryptography: new package
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> [Thomas: - fix license information: it is either Apache-2.0 *or* BSD-3c - add the LICENSE file to the list of license files, since it is the one that explains that the license is either Apache-2.0 or BSD-3c.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-cryptography')
-rw-r--r--package/python-cryptography/Config.in23
-rw-r--r--package/python-cryptography/python-cryptography.hash3
-rw-r--r--package/python-cryptography/python-cryptography.mk15
3 files changed, 41 insertions, 0 deletions
diff --git a/package/python-cryptography/Config.in b/package/python-cryptography/Config.in
new file mode 100644
index 0000000000..9827cf82b6
--- /dev/null
+++ b/package/python-cryptography/Config.in
@@ -0,0 +1,23 @@
+config BR2_PACKAGE_PYTHON_CRYPTOGRAPHY
+ bool "python-cryptography"
+ depends on BR2_INSTALL_LIBSTDCPP # python-pyasn
+ select BR2_PACKAGE_OPENSSL
+ select BR2_PACKAGE_PYTHON_CFFI # runtime
+ select BR2_PACKAGE_PYTHON_IDNA # runtime
+ select BR2_PACKAGE_PYTHON_PYASN # runtime
+ select BR2_PACKAGE_PYTHON_SIX # runtime
+ select BR2_PACKAGE_PYTHON_ENUM34 if BR2_PACKAGE_PYTHON # runtime
+ select BR2_PACKAGE_PYTHON_SETUPTOOLS # runtime
+ select BR2_PACKAGE_PYTHON_PYEXPAT if BR2_PACKAGE_PYTHON # runtime
+ select BR2_PACKAGE_PYTHON3_PYEXPAT if BR2_PACKAGE_PYTHON3 # runtime
+ select BR2_PACKAGE_PYTHON_SSL if BR2_PACKAGE_PYTHON # runtime
+ select BR2_PACKAGE_PYTHON3_SSL if BR2_PACKAGE_PYTHON3 # runtime
+ select BR2_PACKAGE_PYTHON_IPADDRESS if BR2_PACKAGE_PYTHON # runtime
+ help
+ cryptography is a package designed to expose cryptographic
+ primitives and recipes to Python developers.
+
+ https://cryptography.io
+
+comment "python-cryptography needs a toolchain w/ C++"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/python-cryptography/python-cryptography.hash b/package/python-cryptography/python-cryptography.hash
new file mode 100644
index 0000000000..b35f801b2c
--- /dev/null
+++ b/package/python-cryptography/python-cryptography.hash
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi?:action=show_md5&digest=2b25eebd1d3c6bae52b46f0dcec74dfb, sha256 locally computed
+md5 2b25eebd1d3c6bae52b46f0dcec74dfb cryptography-1.2.2.tar.gz
+sha256 3f219cb9106d9b737ea9c332c4d15d70ac328f91b59fd9d79f78bdea8f826a67 cryptography-1.2.2.tar.gz
diff --git a/package/python-cryptography/python-cryptography.mk b/package/python-cryptography/python-cryptography.mk
new file mode 100644
index 0000000000..cefd3cba34
--- /dev/null
+++ b/package/python-cryptography/python-cryptography.mk
@@ -0,0 +1,15 @@
+################################################################################
+#
+# python-cryptography
+#
+################################################################################
+
+PYTHON_CRYPTOGRAPHY_VERSION = 1.2.2
+PYTHON_CRYPTOGRAPHY_SOURCE = cryptography-$(PYTHON_CRYPTOGRAPHY_VERSION).tar.gz
+PYTHON_CRYPTOGRAPHY_SITE = https://pypi.python.org/packages/source/c/cryptography
+PYTHON_CRYPTOGRAPHY_SETUP_TYPE = setuptools
+PYTHON_CRYPTOGRAPHY_LICENSE = Apache-2.0 or BSD-3c
+PYTHON_CRYPTOGRAPHY_LICENSE_FILES = LICENSE LICENSE.APACHE LICENSE.BSD
+PYTHON_CRYPTOGRAPHY_DEPENDENCIES = host-python-cffi openssl
+
+$(eval $(python-package))
OpenPOWER on IntegriCloud