summaryrefslogtreecommitdiffstats
path: root/package/pps-tools
diff options
context:
space:
mode:
authorBryan Brinsko <bryan.brinsko@rockwellcollins.com>2014-10-16 12:30:53 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-19 17:22:37 +0200
commite7db4999254b64a52637cd36edeea14d9c6f6a56 (patch)
treedf844e211cbdbff8bc1f6629a4a6fcab71b19282 /package/pps-tools
parent256db411dbe4e01fedeac43649a82c28071c9be5 (diff)
downloadbuildroot-e7db4999254b64a52637cd36edeea14d9c6f6a56.tar.gz
buildroot-e7db4999254b64a52637cd36edeea14d9c6f6a56.zip
pps-tools: new package
Added pps-tools package to add support to the ntpd for a pps source (requires timepps.h from pps-tools as part of ntpd build). [Thomas: - Use $(TARGET_MAKE_ENV) at install time. - Alphabetic ordering in package/Config.in, noticed by Jerzy Grzegorek.] Signed-off-by: Bryan Brinsko <bryan.brinsko@rockwellcollins.com> Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pps-tools')
-rw-r--r--package/pps-tools/Config.in6
-rw-r--r--package/pps-tools/pps-tools.mk27
2 files changed, 33 insertions, 0 deletions
diff --git a/package/pps-tools/Config.in b/package/pps-tools/Config.in
new file mode 100644
index 0000000000..83308f4f32
--- /dev/null
+++ b/package/pps-tools/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PPS_TOOLS
+ bool "pps-tools"
+ help
+ Pulse per second tools. Provides timepps.h and other PPS utilities.
+
+ https://github.com/ago/pps-tools/
diff --git a/package/pps-tools/pps-tools.mk b/package/pps-tools/pps-tools.mk
new file mode 100644
index 0000000000..78764030bb
--- /dev/null
+++ b/package/pps-tools/pps-tools.mk
@@ -0,0 +1,27 @@
+################################################################################
+#
+# pps-tools
+#
+################################################################################
+
+PPS_TOOLS_VERSION = 0deb9c7e135e9380a6d09e9d2e938a146bb698c8
+PPS_TOOLS_SITE = $(call github,ago,pps-tools,$(PPS_TOOLS_VERSION))
+PPS_TOOLS_INSTALL_STAGING = YES
+PPS_TOOLS_LICENSE = GPLv2+
+PPS_TOOLS_LICENSE_FILES = COPYING
+
+define PPS_TOOLS_BUILD_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) all
+endef
+
+define PPS_TOOLS_INSTALL_STAGING_CMDS
+ mkdir -p $(STAGING_DIR)/usr/include/sys $(STAGING_DIR)/usr/bin
+ $(TARGET_MAKE_ENV) $(MAKE) DESTDIR=$(STAGING_DIR) -C $(@D) install
+endef
+
+define PPS_TOOLS_INSTALL_TARGET_CMDS
+ mkdir -p $(TARGET_DIR)/usr/include/sys $(TARGET_DIR)/usr/bin
+ $(TARGET_MAKE_ENV) $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
+endef
+
+$(eval $(generic-package))
OpenPOWER on IntegriCloud