summaryrefslogtreecommitdiffstats
path: root/package/pkg-utils.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-02-05 10:44:00 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-05 12:09:35 +0100
commit3880a6ab3ca3890e79a7a429a58903217f36770d (patch)
treef275f787ddac92a4e3817b99a58816b43016cde6 /package/pkg-utils.mk
parente7ab4b49f4dd16a1312db3144376f26d4340e15e (diff)
downloadbuildroot-3880a6ab3ca3890e79a7a429a58903217f36770d.tar.gz
buildroot-3880a6ab3ca3890e79a7a429a58903217f36770d.zip
infra: remove redundant $(call) on pkgdir, pkgname, pkgparentdir
When calling make 'functions', the $(call) keyword is only needed if the function takes arguments. For pkgdir, pkgname and pkgparentdir this is not the case, so we can remove the call to make things more readable. Suggested-by: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pkg-utils.mk')
-rw-r--r--package/pkg-utils.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/pkg-utils.mk b/package/pkg-utils.mk
index 851575c547..51dd7384ba 100644
--- a/package/pkg-utils.mk
+++ b/package/pkg-utils.mk
@@ -59,8 +59,8 @@ endef
# pkgdir macro is carefully written to handle the case of the Linux
# package, for which the package directory is an empty string.
pkgdir = $(dir $(lastword $(MAKEFILE_LIST)))
-pkgname = $(lastword $(subst /, ,$(call pkgdir)))
-pkgparentdir = $(patsubst %$(call pkgname)/,%,$(call pkgdir))
+pkgname = $(lastword $(subst /, ,$(pkgdir)))
+pkgparentdir = $(patsubst %$(pkgname)/,%,$(pkgdir))
# Define extractors for different archive suffixes
INFLATE.bz2 = $(BZCAT)
OpenPOWER on IntegriCloud