summaryrefslogtreecommitdiffstats
path: root/package/pkg-python.mk
diff options
context:
space:
mode:
authorFabio Porcedda <fabio.porcedda@gmail.com>2014-02-14 10:55:04 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-14 21:08:35 +0100
commitb2fd9f90e23e25ab6c55f116c2cf3c244d122ec2 (patch)
treec1f67ca23f1efe0a696751a5145e65ad7ea603cd /package/pkg-python.mk
parent6f13130ac9a1a5eebfccbd8c9f04a6ec3f5ceba2 (diff)
downloadbuildroot-b2fd9f90e23e25ab6c55f116c2cf3c244d122ec2.tar.gz
buildroot-b2fd9f90e23e25ab6c55f116c2cf3c244d122ec2.zip
package: add toolchain dependency to every target package
This commit makes the dependency from the target toolchain explicit. This way we can buid from command line a package that use inner-generic-package right after the configuration phase, example: make clean <package-name> Also remove TARGETS_ALL because the only purpose was to add toolchain dependency so it's superseded by this commit. To prevent circular dependency add the new variable <pkgname>_ADD_TOOLCHAIN_DEPENDENCY to avoid adding the toolchain dependency for toolchain packages. This is also a step forward supporting top-level parallel make. Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pkg-python.mk')
-rw-r--r--package/pkg-python.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pkg-python.mk b/package/pkg-python.mk
index 9b3c97af35..f33980aaed 100644
--- a/package/pkg-python.mk
+++ b/package/pkg-python.mk
@@ -142,7 +142,7 @@ endif
# be derived automatically from the dependencies of the corresponding
# target package. For example, target packages need
# host-python-distutilscross, but not host packages.
-$(2)_DEPENDENCIES ?= $(filter-out host-python host-python-setuptools host-python-distutilscross $(1),$(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
+$(2)_DEPENDENCIES ?= $(filter-out host-python host-python-setuptools host-python-distutilscross host-toolchain $(1),$(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
# Target packages need both the python interpreter on the target (for
# runtime) and the python interpreter on the host (for
OpenPOWER on IntegriCloud