summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorClayton Shotwell <clayton.shotwell@rockwellcollins.com>2015-07-11 17:40:14 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-12 00:46:55 +0200
commit4837354fff8cc56916fa10e5ac5f8da73d0cc405 (patch)
tree2197d9612d4ebe443ba9929b9b05c9f4de523dfd /package/pkg-generic.mk
parente1baac68bcb9fb3cb3d2603d238a2ce8e7eb1125 (diff)
downloadbuildroot-4837354fff8cc56916fa10e5ac5f8da73d0cc405.tar.gz
buildroot-4837354fff8cc56916fa10e5ac5f8da73d0cc405.zip
pkg-generic: Fix host _DL_VERSION corner case
In the case when a package has a host version, the package is dependent on the host version, and the version contains a '/', the host version does not evaluate properly. The host version will contain a '_' instead of a '/', resulting in a failed download. To solve this corner case, add a check to see if the _DL_VERSION of the package has been defined before defining the host _DL_VERSION. If the package _DL_VERSION has not been defined yet, then the version string has not been formatted yet and is still good to use. [Arnout: further simplify things by lifting the override over _VERSION out of the condition - it is always the same.] This error occured on a package in a BR2_EXTERNAL that uses a git repo for its remote storage with '/' in the tag names. I do not believe this affects any packages in the Buildroot mainline but it could in the future. [Arnout: rebase on master, fix existing whitespace error in the else branch.] Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 9fe01b8d4d..5f630e4326 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -298,17 +298,17 @@ $(2)_RAWNAME = $$(patsubst host-%,%,$(1))
# Similar for spaces and colons (:) that may appear in date-based revisions for
# CVS.
ifndef $(2)_VERSION
- ifdef $(3)_VERSION
- $(2)_DL_VERSION := $$(strip $$($(3)_VERSION))
- $(2)_VERSION := $$(call sanitize,$$($(3)_VERSION))
+ ifdef $(3)_DL_VERSION
+ $(2)_DL_VERSION := $$($(3)_DL_VERSION)
+ else ifdef $(3)_VERSION
+ $(2)_DL_VERSION := $$($(3)_VERSION)
else
- $(2)_VERSION = undefined
$(2)_DL_VERSION = undefined
endif
else
- $(2)_DL_VERSION := $$(strip $$($(2)_VERSION))
- $(2)_VERSION := $$(call sanitize,$$($(2)_VERSION))
+ $(2)_DL_VERSION := $$(strip $$($(2)_VERSION))
endif
+$(2)_VERSION := $$(call sanitize,$$($(2)_DL_VERSION))
$(2)_BASE_NAME = $(1)-$$($(2)_VERSION)
$(2)_DL_DIR = $$(DL_DIR)/$$($(2)_BASE_NAME)
OpenPOWER on IntegriCloud