summaryrefslogtreecommitdiffstats
path: root/package/pkg-generic.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-29 19:33:17 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-30 23:38:49 +0200
commit48296c5afd24cb7f81693fef70881b9737b55062 (patch)
tree9c3ce701e2a8c30af421c285ab1daa0e82a657cc /package/pkg-generic.mk
parent524a555ad1f81f132aaed0badaece1b8b95c8ae7 (diff)
downloadbuildroot-48296c5afd24cb7f81693fef70881b9737b55062.tar.gz
buildroot-48296c5afd24cb7f81693fef70881b9737b55062.zip
pkg-generic: take into account <pkg>_EXTRA_DOWNLOADS to display "Downloading" message
The .stamp_downloaded target displays the "Downloading" message even if there is really something to download. However, this logic only checks for <pkg>_SOURCE and <pkg>_PATCH: it does not check if something needs to be downloaded in <pkg>_EXTRA_DOWNLOADS. This commit fixes that, which makes sure that the "Downloading" message is displayed if one of the items in <pkg>_EXTRA_DOWNLOADS has not yet been downloaded. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package/pkg-generic.mk')
-rw-r--r--package/pkg-generic.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index b44d476379..003fd693d6 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -76,7 +76,7 @@ ifeq ($(DL_MODE),DOWNLOAD)
$(Q)if test ! -e $(DL_DIR)/$($(PKG)_SOURCE); then \
$(call MESSAGE,"Downloading") ; \
else \
- for p in $($(PKG)_PATCH) ; do \
+ for p in $($(PKG)_PATCH) $($(PKG)_EXTRA_DOWNLOADS) ; do \
if test ! -e $(DL_DIR)/`basename $$p` ; then \
$(call MESSAGE,"Downloading") ; \
break ; \
OpenPOWER on IntegriCloud