summaryrefslogtreecommitdiffstats
path: root/package/pkg-download.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2014-12-08 08:50:14 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-12-08 08:52:25 +0100
commitcf902845e7c23da7acddd82dc591255e4657d730 (patch)
tree0b238fe4ddfa98a758ee3c961c2455ca1281c0a7 /package/pkg-download.mk
parent362047b4d479d854980c9428bbca9d1b0ead5bbc (diff)
downloadbuildroot-cf902845e7c23da7acddd82dc591255e4657d730.tar.gz
buildroot-cf902845e7c23da7acddd82dc591255e4657d730.zip
pkg-download: VERIFY_HASH: use same hash file for host and target downloads
Fixes (or atleast stops the build with a saner description): http://autobuild.buildroot.net/results/1a9/1a9643f8633db038d4fe5ca4a32e4d52e70a3a1a/ We're using the same sources for host and target downloads, so it makes sense to use the same <pkg>.hash file as well to ensure the host version gets verified without us having to maintain a seperate host-<pkg>.hash file. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pkg-download.mk')
-rw-r--r--package/pkg-download.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index f3409bd46e..190b5b7e99 100644
--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -174,7 +174,7 @@ define DOWNLOAD_SCP
$(EXTRA_ENV) support/download/wrapper scp \
$(DL_DIR)/$(2) \
'$(call stripurischeme,$(call qstrip,$(1)))' && \
- $(call VERIFY_HASH,$(PKGDIR)/$($(PKG)_NAME).hash,$(DL_DIR)/$(2))
+ $(call VERIFY_HASH,$(PKGDIR)/$($(PKG)_RAWNAME).hash,$(DL_DIR)/$(2))
endef
define SOURCE_CHECK_SCP
@@ -211,7 +211,7 @@ define DOWNLOAD_WGET
$(EXTRA_ENV) support/download/wrapper wget \
$(DL_DIR)/$(2) \
'$(call qstrip,$(1))' && \
- $(call VERIFY_HASH,$(PKGDIR)/$($(PKG)_NAME).hash,$(DL_DIR)/$(2))
+ $(call VERIFY_HASH,$(PKGDIR)/$($(PKG)_RAWNAME).hash,$(DL_DIR)/$(2))
endef
define SOURCE_CHECK_WGET
@@ -227,7 +227,7 @@ define DOWNLOAD_LOCALFILES
$(EXTRA_ENV) support/download/wrapper cp \
$(DL_DIR)/$(2) \
$(call stripurischeme,$(call qstrip,$(1))) && \
- $(call VERIFY_HASH,$(PKGDIR)/$($(PKG)_NAME).hash,$(DL_DIR)/$(2))
+ $(call VERIFY_HASH,$(PKGDIR)/$($(PKG)_RAWNAME).hash,$(DL_DIR)/$(2))
endef
define SOURCE_CHECK_LOCALFILES
OpenPOWER on IntegriCloud