summaryrefslogtreecommitdiffstats
path: root/package/php-zmq
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-01-28 18:26:28 -0300
committerPeter Korsgaard <peter@korsgaard.com>2014-02-12 15:56:34 +0100
commitefeda1bc487339beeeb9a1b58ab1fb241da6f548 (patch)
tree09723cb9871a1c0ff41a7a6392f78b5c0f03a8df /package/php-zmq
parent3f8b51338432686307f34a1ea44e6ff9a37e6399 (diff)
downloadbuildroot-efeda1bc487339beeeb9a1b58ab1fb241da6f548.tar.gz
buildroot-efeda1bc487339beeeb9a1b58ab1fb241da6f548.zip
php-zmq: new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/php-zmq')
-rw-r--r--package/php-zmq/Config.in17
-rw-r--r--package/php-zmq/php-zmq.mk25
2 files changed, 42 insertions, 0 deletions
diff --git a/package/php-zmq/Config.in b/package/php-zmq/Config.in
new file mode 100644
index 0000000000..f32b5a3d90
--- /dev/null
+++ b/package/php-zmq/Config.in
@@ -0,0 +1,17 @@
+comment "php-zmq needs a toolchain w/ C++, IPv6, largefile, wchar, threads"
+ depends on !(BR2_INSTALL_LIBSTDCPP && BR2_INET_IPV6 && BR2_LARGEFILE \
+ && BR2_USE_WCHAR && BR2_TOOLCHAIN_HAS_THREADS)
+
+config BR2_PACKAGE_PHP_ZMQ
+ bool "php-zmq"
+ depends on BR2_PACKAGE_PHP
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_INET_IPV6
+ depends on BR2_LARGEFILE # util-linux
+ depends on BR2_USE_WCHAR # util-linux
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ select BR2_PACKAGE_ZEROMQ
+ help
+ ZeroMQ messaging bindings for PHP
+
+ http://pecl.php.net/package/zmq
diff --git a/package/php-zmq/php-zmq.mk b/package/php-zmq/php-zmq.mk
new file mode 100644
index 0000000000..2b48a637f8
--- /dev/null
+++ b/package/php-zmq/php-zmq.mk
@@ -0,0 +1,25 @@
+################################################################################
+#
+# php-zmq
+#
+################################################################################
+
+PHP_ZMQ_VERSION = 1.1.2
+PHP_ZMQ_SOURCE = zmq-$(PHP_ZMQ_VERSION).tgz
+PHP_ZMQ_SITE = http://pecl.php.net/get
+# phpize does the autoconf magic
+PHP_ZMQ_DEPENDENCIES = php zeromq host-autoconf host-pkgconf
+PHP_ZMQ_CONF_OPT = --with-php-config=$(STAGING_DIR)/usr/bin/php-config
+PHP_ZMQ_LICENSE = BSD-3c
+PHP_ZMQ_LICENSE_FILES = LICENSE
+
+define PHP_ZMQ_PHPIZE
+ (cd $(@D); \
+ PHP_AUTOCONF=$(HOST_DIR)/usr/bin/autoconf \
+ PHP_AUTOHEADER=$(HOST_DIR)/usr/bin/autoheader \
+ $(STAGING_DIR)/usr/bin/phpize)
+endef
+
+PHP_ZMQ_PRE_CONFIGURE_HOOKS += PHP_ZMQ_PHPIZE
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud