summaryrefslogtreecommitdiffstats
path: root/package/pcre
diff options
context:
space:
mode:
authorSven Neumann <neumann@teufel.de>2013-11-22 22:58:15 +0100
committerPeter Korsgaard <peter@korsgaard.com>2013-11-25 11:01:25 +0100
commitd34c3ea105e81cdb389347f23dd2cde7ed11ba55 (patch)
tree8195299e874c061e4c915754dff73407f1843a92 /package/pcre
parent12da132c2bc6e980abe22ea4d4edfd1792dd5845 (diff)
downloadbuildroot-d34c3ea105e81cdb389347f23dd2cde7ed11ba55.tar.gz
buildroot-d34c3ea105e81cdb389347f23dd2cde7ed11ba55.zip
pcre: add options to enable UTF and UCP support
Allow to compile PCRE with UTF-8/16/32 support and with support for Unicode properties. [Peter: whitespace fix] Signed-off-by: Sven Neumann <neumann@teufel.de> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/pcre')
-rw-r--r--package/pcre/Config.in12
-rw-r--r--package/pcre/pcre.mk2
2 files changed, 14 insertions, 0 deletions
diff --git a/package/pcre/Config.in b/package/pcre/Config.in
index dc92274102..9d3a143365 100644
--- a/package/pcre/Config.in
+++ b/package/pcre/Config.in
@@ -19,4 +19,16 @@ config BR2_PACKAGE_PCRE_32
help
This option builds the 32-bits pcre library, i.e 'libpcre32'
+config BR2_PACKAGE_PCRE_UTF
+ bool "UTF-8/16/32 support in pcre"
+ help
+ This option builds the pcre library with UTF-8/16/32 support
+
+config BR2_PACKAGE_PCRE_UCP
+ bool "Unicode properties support in pcre"
+ select BR2_PACKAGE_PCRE_UTF
+ help
+ This option builds the pcre library with Unicode properties
+ support (implies UTF-8/16/32 support)'
+
endif
diff --git a/package/pcre/pcre.mk b/package/pcre/pcre.mk
index bf86a3daac..26373545e6 100644
--- a/package/pcre/pcre.mk
+++ b/package/pcre/pcre.mk
@@ -19,5 +19,7 @@ endif
PCRE_CONF_OPT += --enable-pcre8
PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_16),--enable-pcre16,--disable-pcre16)
PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_32),--enable-pcre32,--disable-pcre32)
+PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_UTF),--enable-utf,--disable-utf)
+PCRE_CONF_OPT += $(if $(BR2_PACKAGE_PCRE_UCP),--enable-unicode-properties,--disable-unicode-properties)
$(eval $(autotools-package))
OpenPOWER on IntegriCloud