summaryrefslogtreecommitdiffstats
path: root/package/opentyrian
diff options
context:
space:
mode:
authorJulien Boibessot <julien.boibessot@armadeus.com>2014-02-11 09:43:19 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-12 20:57:29 +0100
commit9b8ffcd8f25cede33bcd2dc81ef8682c2acb0b97 (patch)
tree1f42779f55d25482adddba6a5f100d102294959f /package/opentyrian
parent591b02ca7b47fb61a523e9db3d60350d0637b2cc (diff)
downloadbuildroot-9b8ffcd8f25cede33bcd2dc81ef8682c2acb0b97.tar.gz
buildroot-9b8ffcd8f25cede33bcd2dc81ef8682c2acb0b97.zip
Add OpenTyrian package (SDL game)
[Peter: hide -data package if opentyrian isn't enabled] Signed-off-by: Julien Boibessot <julien.boibessot@armadeus.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/opentyrian')
-rw-r--r--package/opentyrian/Config.in24
-rw-r--r--package/opentyrian/opentyrian.mk36
2 files changed, 60 insertions, 0 deletions
diff --git a/package/opentyrian/Config.in b/package/opentyrian/Config.in
new file mode 100644
index 0000000000..3ebcf0841a
--- /dev/null
+++ b/package/opentyrian/Config.in
@@ -0,0 +1,24 @@
+config BR2_PACKAGE_OPENTYRIAN
+ bool "OpenTyrian"
+ select BR2_PACKAGE_SDL
+ select BR2_PACKAGE_OPENTYRIAN_DATA
+ help
+ OpenTyrian is a port of the DOS shoot-em-up Tyrian. It uses SDL,
+ making it easily cross-platform.
+ It requires the original data files to run.
+ A display with minimum 640x480 resolution and a keyboard are needed
+ to play the game.
+ If you want some sound, activate ALSA with OSS emulation.
+
+ http://code.google.com/p/opentyrian/
+
+if BR2_PACKAGE_OPENTYRIAN
+
+config BR2_PACKAGE_OPENTYRIAN_NET
+ bool "network support"
+ default y
+ select BR2_PACKAGE_SDL_NET
+ help
+ Activates network support in OpenTyrian. Will add SDL_net.
+
+endif
diff --git a/package/opentyrian/opentyrian.mk b/package/opentyrian/opentyrian.mk
new file mode 100644
index 0000000000..80465a308f
--- /dev/null
+++ b/package/opentyrian/opentyrian.mk
@@ -0,0 +1,36 @@
+###############################################################################
+#
+# opentyrian
+#
+###############################################################################
+
+OPENTYRIAN_VERSION = 2.1.20130907
+OPENTYRIAN_SITE = http://www.camanis.net/opentyrian/releases/
+OPENTYRIAN_SOURCE = opentyrian-$(OPENTYRIAN_VERSION)-src.tar.gz
+OPENTYRIAN_LICENSE = GPLv2+
+OPENTYRIAN_LICENSE_FILES = COPYING
+
+OPENTYRIAN_DEPENDENCIES = sdl
+
+ifeq ($(BR2_PACKAGE_OPENTYRIAN_NET),y)
+OPENTYRIAN_DEPENDENCIES += sdl_net
+OPENTYRIAN_NETWORK = true
+else
+OPENTYRIAN_NETWORK = false
+endif
+
+define OPENTYRIAN_BUILD_CMDS
+ $(MAKE) PLATFORM=UNIX \
+ CC="$(TARGET_CC)" \
+ STRIP="/bin/true" \
+ SDL_CONFIG="$(STAGING_DIR)/usr/bin/sdl-config" \
+ LDFLAGS="-lm" \
+ WITH_NETWORK="$(OPENTYRIAN_NETWORK)" \
+ -C $(@D) release
+endef
+
+define OPENTYRIAN_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/opentyrian $(TARGET_DIR)/usr/bin/opentyrian
+endef
+
+$(eval $(generic-package))
OpenPOWER on IntegriCloud