summaryrefslogtreecommitdiffstats
path: root/package/nss-pam-ldapd/nss-pam-ldapd.mk
diff options
context:
space:
mode:
authorDoug Kehn <rdkehn@yahoo.com>2015-05-24 14:12:32 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-11-30 23:55:20 +0100
commitb8fc2884d917973380721d48975d13b5fa46e7fc (patch)
tree3da4b79caf3f8caa3d1abdad5235a654fe279c83 /package/nss-pam-ldapd/nss-pam-ldapd.mk
parent0209b529b09868352cbfd456bbfbf47c0d8aa9d6 (diff)
downloadbuildroot-b8fc2884d917973380721d48975d13b5fa46e7fc.tar.gz
buildroot-b8fc2884d917973380721d48975d13b5fa46e7fc.zip
package/nss-pam-ldapd: new package
Name Service Switch (NSS) module that allows your LDAP server to provide user account, group, host name, alias, netgroup, and basically any other information that you would normally get from /etc flat files or NIS. It also provides a Pluggable Authentication Module (PAM) to do authentication to an LDAP server. [Thomas: - bump to version 0.9.6 - use --disable-<foo> rather than --enable-<foo>=no. - fix license information: there is no LICENSE file, it is named COPYING.] Signed-off-by: Doug Kehn <rdkehn@yahoo.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/nss-pam-ldapd/nss-pam-ldapd.mk')
-rw-r--r--package/nss-pam-ldapd/nss-pam-ldapd.mk46
1 files changed, 46 insertions, 0 deletions
diff --git a/package/nss-pam-ldapd/nss-pam-ldapd.mk b/package/nss-pam-ldapd/nss-pam-ldapd.mk
new file mode 100644
index 0000000000..ba250829bb
--- /dev/null
+++ b/package/nss-pam-ldapd/nss-pam-ldapd.mk
@@ -0,0 +1,46 @@
+################################################################################
+#
+# nss-pam-ldapd
+#
+################################################################################
+
+NSS_PAM_LDAPD_VERSION = 0.9.6
+NSS_PAM_LDAPD_SITE = http://arthurdejong.org/nss-pam-ldapd
+NSS_PAM_LDAPD_LICENSE = LGPLv2.1+
+NSS_PAM_LDAPD_LICENSE_FILES = COPYING
+NSS_PAM_LDAPD_INSTALL_STAGING = YES
+
+NSS_PAM_LDAPD_CONF_OPTS = --disable-sasl
+NSS_PAM_LDAPD_DEPENDENCIES = openldap
+
+ifeq ($(BR2_PACKAGE_NSS_PAM_LDAPD_UTILITIES),y)
+NSS_PAM_LDAPD_CONF_OPTS += --enable-utils
+else
+NSS_PAM_LDAPD_CONF_OPTS += --disable-utils
+endif
+
+ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
+NSS_PAM_LDAPD_CONF_OPTS += --enable-pam
+NSS_PAM_LDAPD_DEPENDENCIES += linux-pam
+else
+NSS_PAM_LDAPD_CONF_OPTS += --disable-pam
+endif
+
+define NSS_PAM_LDAPD_INSTALL_INIT_SYSTEMD
+ $(INSTALL) -m 755 -D package/nss-pam-ldapd/nslcd.service \
+ $(TARGET_DIR)/usr/lib/systemd/system/nslcd.service
+ mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
+ ln -fs ../../../../usr/lib/systemd/system/nslcd.service \
+ $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/nslcd.service
+endef
+
+define NSS_PAM_LDAPD_INSTALL_INIT_SYSV
+ $(INSTALL) -m 755 -D package/nss-pam-ldapd/S45nslcd \
+ $(TARGET_DIR)/etc/init.d/S45nslcd
+endef
+
+define NSS_PAM_LDAPD_USERS
+ nslcd -1 nslcd -1 * - - - nslcd user
+endef
+
+$(eval $(autotools-package))
OpenPOWER on IntegriCloud